aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorchamptar <champetier.etienne@gmail.com>2017-09-23 16:09:57 -0700
committerGitHub <noreply@github.com>2017-09-23 16:09:57 -0700
commit088c66a5efe617c499b54f96c081d03efa4fe2da (patch)
tree560f520af5b4806ba3ed2f0f15ec4713862ae772 /lang
parent86605ec7e271ba7dad1c896a8b2a6589c97155f3 (diff)
parent617441d0a94b3755f10923f976c68fd31cd9f766 (diff)
Merge pull request #4824 from nxhack/node-arduino-firmata_fix_depends
node-arduino-firmata: Correct multiple DEPENDS lines
Diffstat (limited to 'lang')
-rw-r--r--lang/node-arduino-firmata/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/node-arduino-firmata/Makefile b/lang/node-arduino-firmata/Makefile
index a9792f353..9dea3bc42 100644
--- a/lang/node-arduino-firmata/Makefile
+++ b/lang/node-arduino-firmata/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=arduino-firmata
PKG_NAME:=node-$(PKG_NPM_NAME)
PKG_VERSION:=0.3.3
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/shokai/node-arduino-firmata.git
@@ -20,7 +20,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MIRROR_HASH:=b7a498ccf70e466503e72d38ae5b474e91416b6c9842fd167dff249357b0dc37
PKG_BUILD_DEPENDS:=node/host
-PKG_NODE_VERSION:=4.4.5
+PKG_NODE_VERSION:=6.11.2
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_LICENSE:=MIT
@@ -29,13 +29,12 @@ PKG_LICENSE_FILES:=LICENSE.txt
include $(INCLUDE_DIR)/package.mk
define Package/node-arduino-firmata
- DEPENDS:=+node +node-npm
SUBMENU:=Node.js
SECTION:=lang
CATEGORY:=Languages
- DEPENDS:=+node +node-serialport
TITLE:=Node.js package to access serial ports for reading and writing
URL:=https://www.npmjs.org/package/serialport
+ DEPENDS:=+node +node-npm +node-serialport
endef
define Package/node-arduino-firmata/description