aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-27 23:25:16 -0800
committerRosen Penev <rosenp@gmail.com>2019-11-27 23:29:54 -0800
commit1b2e94e537e901b989727514f591be8140718f88 (patch)
tree1fba2f5e98ba24625807c45bac5ecbc970ca8882 /lang/tcl
parent04e94b44b50071991458e7733fef2dbb9e5bb641 (diff)
tcl: Fix pkgconfig file
It's pointing to the host. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'lang/tcl')
-rw-r--r--lang/tcl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/tcl/Makefile b/lang/tcl/Makefile
index a4f310a42..0dc6fd0db 100644
--- a/lang/tcl/Makefile
+++ b/lang/tcl/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tcl
TCL_MAJOR_VERSION:=8.6
PKG_VERSION:=${TCL_MAJOR_VERSION}.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION)-src.tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -74,6 +74,8 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/tcl.pc \
$(1)/usr/lib/pkgconfig
+ $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/tcl.pc
+ $(SED) 's,/usr/lib,$$$${prefix}/lib,g' $(1)/usr/lib/pkgconfig/tcl.pc
endef
define Package/tcl/install