aboutsummaryrefslogtreecommitdiff
path: root/lang/rust
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-25 11:28:45 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-11 15:50:22 +0800
commitd24095b8fc5b8d4e509d59f73d6901842b50c4bd (patch)
treeca1cbc7109079dccb1d7bf61739494b24a300624 /lang/rust
parenta00dae9ed071030426a9e2c624aec58bb62538f0 (diff)
rust: Add RUST_HOST_FEATURES for host builds
Features to be enabled for host may not be the same as those for target. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/rust-host-build.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/lang/rust/rust-host-build.mk b/lang/rust/rust-host-build.mk
index 39cf1f23c..39bee072e 100644
--- a/lang/rust/rust-host-build.mk
+++ b/lang/rust/rust-host-build.mk
@@ -2,6 +2,14 @@
#
# Copyright (C) 2023 Luca Barbato and Donald Hoskins
+# Variables (all optional) to be set in package Makefiles:
+#
+# RUST_HOST_FEATURES - list of options, default empty
+#
+# Space or comma separated list of features to activate
+#
+# e.g. RUST_HOST_FEATURES:=enable-foo,with-bar
+
ifeq ($(origin RUST_INCLUDE_DIR),undefined)
RUST_INCLUDE_DIR:=$(dir $(lastword $(MAKEFILE_LIST)))
endif
@@ -17,7 +25,7 @@ define Host/Compile/Cargo
CC=$(HOSTCC_NOCACHE) \
cargo install -v \
--profile stripped \
- $(if $(RUST_PKG_FEATURES),--features "$(RUST_PKG_FEATURES)") \
+ $(if $(RUST_HOST_FEATURES),--features "$(RUST_HOST_FEATURES)") \
--root $(HOST_INSTALL_DIR) \
--path "$(if $(strip $(1)),$(strip $(1)),.)" $(2) ; \
)