aboutsummaryrefslogtreecommitdiff
path: root/lang/rust
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-03-19 14:20:40 +0800
committerTianling Shen <cnsztl@gmail.com>2023-03-24 02:08:47 +0800
commit09d482c3b2d34000d34cf84fdaa4d23aa88ea76b (patch)
treeb40cc100751f82f24dff1ce1ee53b10819191945 /lang/rust
parentbc4d9429de708bc13d7370a73248159e6b8f56d4 (diff)
rust: enable use of prebuilt llvm toolchain
llvm-bpf is not ready for generic usage, so use prebuilt llvm toolchain provided by the rust project to speedup build (~1hour faster). Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 1c47fbf76..3cdb633ab 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -66,13 +66,11 @@ HOST_CONFIGURE_ARGS = \
--datadir=$(CARGO_HOME)/share \
--mandir=$(CARGO_HOME)/man \
--dist-compression-formats=xz \
- --enable-llvm-link-shared \
- --enable-llvm-plugins \
--enable-missing-tools \
- --enable-ninja \
--disable-sanitizers \
--release-channel=stable \
--enable-cargo-native-static \
+ --set=llvm.download-ci-llvm=true \
$(TARGET_CONFIGURE_ARGS)
define Host/Uninstall