aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/rust-values.mk
diff options
context:
space:
mode:
authorDrew Young <dyoung@viridiparente.com>2023-10-09 17:19:50 -0400
committerTianling Shen <cnsztl@gmail.com>2023-10-16 09:01:43 +0800
commit3d799c3eeedfe8813ca3fb2debadffb231f621c1 (patch)
treef1d79e24d2e6fad8988e07475b33b8390b3512c9 /lang/rust/rust-values.mk
parentf151ab8c0e6becdabc146e3c2fd1aa2d02708bd4 (diff)
rust: fix build with glibc, ARM and hard floats
Patch the target triple for Rust with glibc to include hard floating point support. The GNU target triple used elsewhere does not include hard float support, instead `-mfloat-abi=hard` is passed separately. For Rust it must be included in the target triple. This was already being done for musl, this commit adds the same patching for glibc. Without this patch Rust compilation fails with an error like this (abbreviated to fit the line length): ld: error: libstd.so uses VFP register arguments, ... does not ld: failed to merge target specific data of file ... Signed-off-by: Drew Young <dyoung@viridiparente.com>
Diffstat (limited to 'lang/rust/rust-values.mk')
-rw-r--r--lang/rust/rust-values.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/rust/rust-values.mk b/lang/rust/rust-values.mk
index 4c21c2752..7a4d1fcf8 100644
--- a/lang/rust/rust-values.mk
+++ b/lang/rust/rust-values.mk
@@ -52,6 +52,7 @@ ifeq ($(ARCH),arm)
ifeq ($(CONFIG_HAS_FPU),y)
RUSTC_TARGET_ARCH:=$(subst musleabi,musleabihf,$(RUSTC_TARGET_ARCH))
+ RUSTC_TARGET_ARCH:=$(subst gnueabi,gnueabihf,$(RUSTC_TARGET_ARCH))
endif
endif