aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/rust-package.mk
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-13 04:27:11 +0800
committerJeffery To <jeffery.to@gmail.com>2023-09-13 04:27:11 +0800
commit985738b3991611be3b0b85e2b47cfb3ef0bbc335 (patch)
treec6ae91a4c89325e0bfad4e56834c35a51c70df6f /lang/rust/rust-package.mk
parenta56e111c499f6d5896ffe9b1bdab0fb0072ee735 (diff)
rust: Move RUST_ARCH_DEPENDS into rust-values.mk
This allows other packages access to RUST_ARCH_DEPENDS by including rust-values.mk, instead of rust-package.mk which also sets Build/Compile. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/rust/rust-package.mk')
-rw-r--r--lang/rust/rust-package.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/lang/rust/rust-package.mk b/lang/rust/rust-package.mk
index 955b37c29..e8cf7d712 100644
--- a/lang/rust/rust-package.mk
+++ b/lang/rust/rust-package.mk
@@ -15,9 +15,6 @@ ifeq ($(origin RUST_INCLUDE_DIR),undefined)
endif
include $(RUST_INCLUDE_DIR)/rust-values.mk
-# Support only a subset for now.
-RUST_ARCH_DEPENDS:=@(aarch64||arm||i386||i686||mips||mipsel||mips64||mips64el||mipsel||powerpc64||riscv64||x86_64)
-
# $(1) path to the package (optional)
# $(2) additional arguments to cargo (optional)
define Build/Compile/Cargo