aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/rust-package.mk
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2023-02-08 15:18:41 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-03-10 14:24:16 +0000
commit83785a7ce01613ed6408bed4d96bd5eea711bc01 (patch)
tree5ccd70d6be235938d7aeca88a11a1a417973b216 /lang/rust/rust-package.mk
parent772db8c11b6ef3d3930f8c94b8fc073124415d30 (diff)
rust-lang: Add the rust language support
Based on work from Donald Hoskins <grommish@gmail.com>. Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
Diffstat (limited to 'lang/rust/rust-package.mk')
-rw-r--r--lang/rust/rust-package.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/lang/rust/rust-package.mk b/lang/rust/rust-package.mk
new file mode 100644
index 000000000..3c8b7aaa0
--- /dev/null
+++ b/lang/rust/rust-package.mk
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2023 Luca Barbato and Donald Hoskins
+
+rust_mk_path:=$(dir $(lastword $(MAKEFILE_LIST)))
+include $(rust_mk_path)rust-host.mk
+
+# $(1) path to the package
+# $(2) additional arguments to cargo
+define Build/Compile/Cargo
+ cd $(PKG_BUILD_DIR) && \
+ export PATH="$(CARGO_HOME)/bin:$(PATH)" && \
+ CARGO_HOME=$(CARGO_HOME) TARGET_CFLAGS="$(TARGET_CFLAGS) $(RUST_CFLAGS)" TARGET_CC=$(TARGET_CC_NOCACHE) CC=cc \
+ cargo install -v --profile stripped --target $(RUSTC_TARGET_ARCH) --root $(PKG_INSTALL_DIR) --path "$(if $(strip $(1)),$(strip $(1)),.)" $(2)
+endef