aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/maturin/Makefile
diff options
context:
space:
mode:
authorLuca Barbato <luca.barbato@gmail.com>2023-03-09 08:58:16 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-03-10 14:24:16 +0000
commit44d1d22a16e25b1e06fae86e157718069b7069f6 (patch)
treec8ffc0bae5ec9debda98ca059a30ed489ffd89fc /lang/rust/maturin/Makefile
parent674bad05591f2c969297576062b9dcba00a30ea7 (diff)
rust-lang: Apply suggestions from code review
Co-authored-by: Tianling Shen <cnsztl@gmail.com> Signed-off-by: Luca Barbato <luca.barbato@gmail.com>
Diffstat (limited to 'lang/rust/maturin/Makefile')
-rw-r--r--lang/rust/maturin/Makefile43
1 files changed, 24 insertions, 19 deletions
diff --git a/lang/rust/maturin/Makefile b/lang/rust/maturin/Makefile
index c19a86758..0249bf9ad 100644
--- a/lang/rust/maturin/Makefile
+++ b/lang/rust/maturin/Makefile
@@ -8,40 +8,45 @@ PKG_NAME:=maturin
PKG_VERSION:=0.14.10
PKG_RELEASE:=1
-PKG_SOURCE:=v$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/PyO3/maturin/archive/refs/tags/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/PyO3/maturin/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=8fc9bcdcb7f1535d5e3e8bb500c348ca1bff5a6dce87b0ab7dbc5a49723da28a
-PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
-PKG_HOST_ONLY:=1
-PKG_BUILD_PARALLEL:=1
+PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
+PKG_LICENSE:=Apache-2.0 MIT
+PKG_LICENSE_FILES:=license-apache license-mit
HOST_BUILD_DEPENDS:=rust/host
PKG_BUILD_DEPENDS:=rust/host
+PKG_BUILD_PARALLEL:=1
+PKG_HOST_ONLY:=1
+
include ../rust-package.mk
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
-define Package/$(PKG_NAME)
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Rust
- CATEGORY:=Languages
- DEPENDS:=$(RUST_ARCH_DEPENDS)
- TITLE:=Build and publish crates as python packages
- URL:=https://maturin.rs
+define Package/maturin
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Rust
+ TITLE:=Build and publish crates as python packages
+ DEPENDS:=$(RUST_ARCH_DEPENDS)
+ URL:=https://maturin.rs
endef
define Host/Compile
- cd $(HOST_BUILD_DIR) && \
- export PATH="$(CARGO_HOME)/bin:$(PATH)" && \
- CARGO_HOME=$(CARGO_HOME) \
- cargo install --path . --root $(HOST_BUILD_DIR)
+ ( \
+ cd $(HOST_BUILD_DIR) ; \
+ export PATH="$(CARGO_HOME)/bin:$(PATH)" ; \
+ CARGO_HOME=$(CARGO_HOME) \
+ cargo install --path . --root $(HOST_BUILD_DIR) ; \
+ )
endef
-define Package/$(PKG_NAME)/description
-Build and publish crates with pyo3, rust-cpython, cffi and uniffi bindings as well as rust binaries as python packages.
+define Package/maturin/description
+ Build and publish crates with pyo3, rust-cpython, cffi and uniffi
+ bindings as well as rust binaries as python packages.
endef
define Host/Install