aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2015-12-16 18:02:44 -0200
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2015-12-22 18:54:19 -0200
commitfbd2b86dcaed5b272bf74dbbf83941afe9b327f5 (patch)
tree21c1479109cb8359297d5c87f859fb7b65c2942f /lang/ruby
parente26fc30eb9b57a3f063028fa0296a48179c03512 (diff)
ruby: bump to 2.2.4
This release includes a security fix for Fiddle extension. * CVE-2015-7551: Unsafe tainted string usage in Fiddle and DL There are also some bugfixes. In package, now LD_FLAGS is copied to DLD_FLAGS (used by ruby for libraries). The missing values from LD_FLAGS cause build error when gcc does not implicitly include staging/usr/lib. Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'lang/ruby')
-rw-r--r--lang/ruby/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 210d63319..3922dad16 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -10,14 +10,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ruby
-PKG_VERSION:=2.2.3
+PKG_VERSION:=2.2.4
PKG_RELEASE:=1
PKG_LIBVER:=2.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://cache.ruby-lang.org/pub/ruby/$(PKG_LIBVER)/
-PKG_MD5SUM:=f49a734729a71774d4a94a9a603114b2
+PKG_MD5SUM:=c3d65f6d2ebe90dda81a37885ea244f5
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=BSD-2-Clause
PKG_LICENSE_FILES:=COPYING
@@ -833,6 +833,13 @@ endif
TARGET_LDFLAGS += -L$(PKG_BUILD_DIR)
+# Ruby uses DLDFLAGS and not LDFLAGS for libraries. LDFLAGS is only for execs.
+# However, DLDFLAGS from configure is not passed to Makefile when target is linux.
+# XLDFLAGS is used by both libraries and execs. This is somehow brute force but
+# if will fix when some LD_FLAGS is needef for libraries. As side effect, it will
+# duplicate ld args for binaries.
+CONFIGURE_VARS += XLDFLAGS="$(TARGET_LDFLAGS)"
+
MAKE_FLAGS += \
DESTDIR="$(PKG_INSTALL_DIR)" \
SHELL="/bin/bash"