aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby/patches
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2020-12-28 00:27:40 -0300
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2021-02-22 19:49:38 -0300
commitfe4020f23e0ba93aa9d5abef3ce4fee079f03f85 (patch)
treef0551f68e6d2e5a5a31c0ba6135d60caccbd729e /lang/ruby/patches
parent39d976ba877f8dc8cf9e5cdef1fce02bb8876810 (diff)
ruby: update to 3.0.0
This release goal is performance, concurrency, and typing. See details in https://www.ruby-lang.org/en/news/2020/12/25/ruby-3-0-0-released/ New subpackages (reflect of mostly complete upstream ruby gemification) - ruby-abbrev (from ruby-misc) - ruby-base64 (from ruby-misc) - ruby-coverage (from ruby-misc) - ruby-continuation (from ruby-misc) - ruby-debug (from ruby-debuglib) - ruby-english (from ruby-misc) - ruby-expect (from ruby-misc) - ruby-fiber (from ruby-misc) - ruby-find (from ruby-filelib) - ruby-io-nonblock (from ruby-multithread) - ruby-io-wait (from ruby-multithread) - ruby-monitor (from ruby-multithread) - ruby-net-ftp (from ruby-net) - ruby-net-http (from ruby-net) - ruby-net-imap (from ruby-net) - ruby-net-pop (from ruby-net) - ruby-net-protocol (from ruby-net) - ruby-objspace (from ruby-debuglib) - ruby-open-uri (from ruby-net) - ruby-pathname (from ruby-filelib) - ruby-pp (from ruby-prettyprint) - ruby-pty (from ruby-misc) - ruby-rbs (NEW) - ruby-resolv (from ruby-socket) - ruby-resolv-replace (from ruby-socket) - ruby-securerandom (from ruby-misc) - ruby-set (from ruby-misc) - ruby-shellwords (from ruby-misc) - ruby-syslog (from ruby-logger) - ruby-tempfile (from ruby-filelib) - ruby-tmpdir (from ruby-filelib) - ruby-tsort (from ruby-misc) - ruby-typeprof (NEW) - ruby-un (from ruby-mkmf) - ruby-weakref (from ruby-misc) Removed subpackages - ruby-debuglib (split into ruby-debug,ruby-objspace) - ruby-filelib (split into ruby-find,ruby-pathname,ruby-tempfile,ruby-tmpdir) - ruby-misc (split into ruby-abbrev,ruby-base64,ruby-continuation, ruby-coverage,ruby-english,ruby-expect,ruby-fiber,ruby-securerandom, ruby-set,ruby-shellwords,ruby-tsort,ruby-weakref) - ruby-multithread (split into ruby-io-nonblock,ruby-io-wait,ruby-monitor) - ruby-net (split into ruby-net-ftp,ruby-net-http,ruby-net-imap,ruby-net-pop, ruby-net-protocol,ruby-open-uri) - ruby-net-telnet (removed upstream) - ruby-sdbm (removed upstream) - ruby-webrick (removed upstream) - ruby-xmlrpc (removed upstream) Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'lang/ruby/patches')
-rw-r--r--lang/ruby/patches/100-musl.patch17
1 files changed, 5 insertions, 12 deletions
diff --git a/lang/ruby/patches/100-musl.patch b/lang/ruby/patches/100-musl.patch
index 29936cc1a..7ae57f010 100644
--- a/lang/ruby/patches/100-musl.patch
+++ b/lang/ruby/patches/100-musl.patch
@@ -1,19 +1,12 @@
---- a/coroutine/copy/Context.h
-+++ b/coroutine/copy/Context.h
-@@ -13,6 +13,7 @@
- #include <string.h>
- #include <stdlib.h>
- #include <alloca.h>
-+#include <sys/types.h>
-
- #define COROUTINE __attribute__((noreturn)) void
-
+Rebased on https://patch-diff.githubusercontent.com/raw/ruby/ruby/pull/2995.patch
+which was originally based on this file.
+
--- a/configure.ac
+++ b/configure.ac
-@@ -2347,7 +2347,10 @@ AS_CASE([$rb_cv_coroutine], [yes|''], [
+@@ -2441,7 +2441,10 @@ AS_CASE([$rb_cv_coroutine], [yes|''], [
rb_cv_coroutine=copy
],
- [*], [
+ [
- rb_cv_coroutine=ucontext
+ AC_CHECK_FUNCS([getcontext swapcontext makecontext],
+ [rb_cv_coroutine=ucontext],