aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby/Makefile
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2014-10-04 19:31:20 -0300
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2014-10-07 14:14:53 -0300
commite6541de61d607d3ae8dbdb48e3043236e9db3111 (patch)
tree50503cb5bf1a1a2f37d2fcbd60ce7a28722ce093 /lang/ruby/Makefile
parente707020e183d67ecf6684302c5d22e00cccfa4de (diff)
ruby: create subpkgs ruby-enc-extra from ruby-enc
Ruby encoding library was too big and bring unecessary encodings for a simple ruby usage. All not directly required encodings from stdlib where moved to ruby-enc-extra. Created pkg from ruby-enc - ruby-enc-extra (from ruby-enc) Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'lang/ruby/Makefile')
-rw-r--r--lang/ruby/Makefile24
1 files changed, 22 insertions, 2 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 38a243f54..06d1b1987 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -7,7 +7,6 @@
#
# To Do:
-# - split up encodings
# - allow selection of either native or pure version of a library where supported
# +-> some native libraries are probably only supported if ruby-dl is enabled
# anything else?
@@ -119,10 +118,16 @@ endef
define Package/ruby-enc
$(call Package/ruby/Default)
- TITLE+= (character re-coding library) (adds 2MB+)
+ TITLE:=Ruby character re-coding library charset (small subset)
DEPENDS:=ruby
endef
+define Package/ruby-enc-extra
+$(call Package/ruby/Default)
+ TITLE:=Ruby character re-coding library charset (extra subset)
+ DEPENDS:=ruby +ruby-enc
+endef
+
define Package/ruby-erb
$(call Package/ruby/Default)
TITLE+= (embedded interpreter)
@@ -406,6 +411,20 @@ endef
define Package/ruby-enc/install
( cd $(PKG_INSTALL_DIR); $(TAR) -cf - \
+ usr/lib/ruby/$(PKG_LIBVER)/*/enc/encdb.so \
+ usr/lib/ruby/$(PKG_LIBVER)/*/enc/iso_8859_1.so \
+ usr/lib/ruby/$(PKG_LIBVER)/*/enc/utf_* \
+ usr/lib/ruby/$(PKG_LIBVER)/*/enc/euc_jp.so \
+ ) | ( cd $(1); $(TAR) -xf - )
+endef
+
+define Package/ruby-enc-extra/install
+ ( cd $(PKG_INSTALL_DIR); $(TAR) \
+ --exclude=usr/lib/ruby/$(PKG_LIBVER)/*/enc/encdb.so \
+ --exclude=usr/lib/ruby/$(PKG_LIBVER)/*/enc/iso_8859_1.so \
+ --exclude=usr/lib/ruby/$(PKG_LIBVER)/*/enc/utf_* \
+ --exclude=usr/lib/ruby/$(PKG_LIBVER)/*/enc/euc_jp.so \
+ -cf - \
usr/lib/ruby/$(PKG_LIBVER)/*/enc \
) | ( cd $(1); $(TAR) -xf - )
endef
@@ -593,6 +612,7 @@ $(eval $(call BuildPackage,ruby-cgi))
$(eval $(call BuildPackage,ruby-digest))
$(eval $(call BuildPackage,ruby-dl))
$(eval $(call BuildPackage,ruby-enc))
+$(eval $(call BuildPackage,ruby-enc-extra))
$(eval $(call BuildPackage,ruby-erb))
$(eval $(call BuildPackage,ruby-gdbm))
$(eval $(call BuildPackage,ruby-gems))