aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-08-20 14:42:10 +0200
committerNicolas Thill <nico@openwrt.org>2014-08-20 15:12:18 +0200
commit84c04a73e65c2fe74d9443b7104664b58b97cc8c (patch)
treeacaf077a321a070120176045c662c6869ac33514 /lang/ruby/Makefile
parent7df0f9bbbde22ab269b3f67e5318fec3c51a27aa (diff)
ruby: fix ruby/host build
- build ruby/host extensions as static, - remove dependency on gmp/host Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'lang/ruby/Makefile')
-rw-r--r--lang/ruby/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 661b3e725..be2a669ed 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -32,8 +32,6 @@ PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
-HOST_BUILD_DEPENDS:=gmp/host
-
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -210,7 +208,8 @@ endef
HOST_CONFIGURE_ARGS += \
--disable-install-doc \
--disable-install-rdoc \
- --disable-install-capi
+ --disable-install-capi \
+ --with-static-linked-ext \
CONFIGURE_ARGS += \
--enable-shared \