aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby/Makefile
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2014-08-20 00:33:29 -0300
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2014-08-20 00:33:29 -0300
commit0ecf63a655b1ef48f68c1f5ef0ec32db4d10adc2 (patch)
treec39feb75657a53074723a3a256ef843708044d4d /lang/ruby/Makefile
parent400e4dee634eaf7359d33ee8510b4c6be059fae6 (diff)
ruby: Fix build dependency of gmp/host
libgmp.so is needed for miniruby, that is compiled in host. Using PKG_BUILD_DEPENDS=gmp/host eventually compiled gmp/host before ruby/host. However, when this did not happened, build failed. Using HOST_BUILD_DEPENDS=gmp/host seems to be the correct way to require it. Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'lang/ruby/Makefile')
-rw-r--r--lang/ruby/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index a37d89f15..661b3e725 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -27,11 +27,13 @@ PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=BSD-2-Clause
PKG_LICENSE_FILE:=COPYING
-PKG_BUILD_DEPENDS:=ruby/host gmp/host
+PKG_BUILD_DEPENDS:=ruby/host
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
+HOST_BUILD_DEPENDS:=gmp/host
+
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk