aboutsummaryrefslogtreecommitdiff
path: root/lang/pytz
diff options
context:
space:
mode:
authorGergely Kiss <mail.gery@gmail.com>2016-04-30 10:37:30 +0200
committerEtienne CHAMPETIER <champetier.etienne@gmail.com>2016-08-24 20:35:33 +0000
commit437621931a1561ae23604c619fde40f78d750c3c (patch)
tree59c792f612d9fb2f199d18e2397e3487248dbb1d /lang/pytz
parent39e937fae7608da2e260505e312d8d5f5ed7a225 (diff)
seafile: import version 5.1.1 and its dependencies
Signed-off-by: Gergely Kiss <mail.gery@gmail.com>
Diffstat (limited to 'lang/pytz')
-rw-r--r--lang/pytz/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/lang/pytz/Makefile b/lang/pytz/Makefile
new file mode 100644
index 000000000..3d40a4094
--- /dev/null
+++ b/lang/pytz/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2007-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pytz
+PKG_VERSION:=2016.3
+PKG_RELEASE:=1
+PKG_LICENSE:=MIT
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://pypi.python.org/packages/source/p/pytz/
+PKG_MD5SUM:=abae92c3301b27bd8a9f56b14f52cb29
+PKG_BUILD_DEPENDS:=python python-setuptools
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/pytz
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
+ TITLE:=World timezone definitions, modern and historical
+ URL:=https://sourceforge.net/projects/pytz/
+ DEPENDS:=+python
+endef
+
+define Package/pytz/description
+ World timezone definitions, modern and historical
+endef
+
+define Build/Compile
+ $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+endef
+
+define Package/pytz/install
+ $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+ $(CP) \
+ $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+ $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,pytz))