aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-05 05:48:07 +0800
committerJeffery To <jeffery.to@gmail.com>2023-09-05 05:48:07 +0800
commitfdff92f0855d40d65a77d47e0e0db8e23f75a1f3 (patch)
treea9cfa6cced6e57d0cc1705caa542ab33a3e3951d /lang/python
parent1e1b2051db47a82513f4eb4e9da892207785b7e2 (diff)
ruamel-yaml: Update to 0.17.32, rename source package
This renames the source package to python-ruamel-yaml to match other Python packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python-ruamel-yaml/Makefile (renamed from lang/python/ruamel-yaml/Makefile)13
1 files changed, 7 insertions, 6 deletions
diff --git a/lang/python/ruamel-yaml/Makefile b/lang/python/python-ruamel-yaml/Makefile
index fd8f17a7f..a63b1642b 100644
--- a/lang/python/ruamel-yaml/Makefile
+++ b/lang/python/python-ruamel-yaml/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=ruamel-yaml
-PKG_VERSION:=0.17.17
+PKG_NAME:=python-ruamel-yaml
+PKG_VERSION:=0.17.32
PKG_RELEASE:=1
PYPI_NAME:=ruamel.yaml
-PKG_HASH:=9751de4cbb57d4bfbf8fc394e125ed4a2f170fbff3dc3d78abf50be85924f8be
+PKG_HASH:=ec939063761914e14542972a5cba6d33c23b0859ab6342f61cf070cfc600efc2
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=MIT
@@ -26,14 +26,15 @@ define Package/python3-ruamel-yaml
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
- TITLE:=YAML 1.2 loader/dumper package for Python
- URL:=https://bitbucket.org/ruamel/yaml
+ TITLE:=YAML 1.2 loader/dumper
+ URL:=https://sourceforge.net/p/ruamel-yaml/code/ci/default/tree
DEPENDS:= \
+python3-light
endef
define Package/python3-ruamel-yaml/description
-ruamel-yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order
+ruamel-yaml is a YAML parser/emitter that supports roundtrip
+preservation of comments, seq/map flow style, and map key order
endef
$(eval $(call Py3Package,python3-ruamel-yaml))