aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-13 12:13:52 +0800
committerRosen Penev <rosenp@gmail.com>2023-09-27 16:40:55 -0700
commitf467f47f0ca226e382356a8e3615b5c55655b692 (patch)
treed0104964729de515a0a0b962baf0e22adea76c83 /lang/python
parentb078e01f0c60354b8580fed8b12c25b5a5706cc6 (diff)
python-setuptools-rust: Add new host-only package
From the README: setuptools-rust is a plugin for setuptools to build Rust Python extensions implemented with PyO3 or rust-cpython. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python-setuptools-rust/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/lang/python/python-setuptools-rust/Makefile b/lang/python/python-setuptools-rust/Makefile
new file mode 100644
index 000000000..19325c1fd
--- /dev/null
+++ b/lang/python/python-setuptools-rust/Makefile
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-setuptools-rust
+PKG_VERSION:=1.7.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=setuptools-rust
+PKG_HASH:=c7100999948235a38ae7e555fe199aa66c253dc384b125f5d85473bf81eae3a3
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_HOST_ONLY:=1
+HOST_BUILD_DEPENDS:= \
+ python3/host \
+ python-build/host \
+ python-installer/host \
+ python-wheel/host \
+ python-setuptools-scm/host \
+ python-semantic-version/host \
+ python-typing-extensions/host \
+ rust/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-setuptools-rust
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Setuptools Rust extension plugin
+ URL:=https://github.com/PyO3/setuptools-rust
+ DEPENDS:= \
+ +python3-light \
+ +python3-logging \
+ +python3-semantic-version \
+ +python3-setuptools \
+ +python3-typing-extensions \
+ +rust
+ BUILDONLY:=1
+endef
+
+define Package/python3-setuptools-rust/description
+setuptools-rust is a plugin for setuptools to build Rust Python
+extensions implemented with PyO3 or rust-cpython.
+endef
+
+$(eval $(call Py3Package,python3-setuptools-rust))
+$(eval $(call BuildPackage,python3-setuptools-rust))
+$(eval $(call BuildPackage,python3-setuptools-rust-src))
+$(eval $(call HostBuild))