aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-02-28 14:36:12 +0800
committerJeffery To <jeffery.to@gmail.com>2023-03-31 13:01:51 +0800
commite9dd1a1dfc0dc924a1e9d7ea448ca27591574557 (patch)
tree8c7b3a033d058673b561be351431bc602f54d5cf /lang/python
parent37caea7c93bbdbf3ce1d44cdc762b1d920a59e57 (diff)
python-packaging: Update to 23.0, add host build
This also adds myself as maintainer, and marks the target package as BROKEN (for now) as the update requires proper support for pyproject.toml-based builds. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python-packaging/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/lang/python/python-packaging/Makefile b/lang/python/python-packaging/Makefile
index 6a0eaad75..c727c20aa 100644
--- a/lang/python/python-packaging/Makefile
+++ b/lang/python/python-packaging/Makefile
@@ -7,19 +7,24 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-packaging
-PKG_VERSION:=20.9
+PKG_VERSION:=23.0
PKG_RELEASE:=1
PYPI_NAME:=packaging
-PKG_HASH:=5b327ac1320dc863dca72f4514ecc086f31186744b84a230374cc1fd776feae5
+PKG_HASH:=b6ad297f8907de0fa2fe1ccbd26fdaf387f5f47c7275fedf8cce89f99446cf97
-PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>, Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=Apache-2.0 BSD-2-Clause
PKG_LICENSE_FILES:=LICENSE.APACHE LICENSE.BSD
+PKG_BUILD_DEPENDS:=python-flit-core/host
+HOST_BUILD_DEPENDS:=python3/host python-flit-core/host python-installer/host
+
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
include ../python3-package.mk
+include ../python3-host-build.mk
define Package/python3-packaging
SECTION:=lang
@@ -27,7 +32,7 @@ define Package/python3-packaging
SUBMENU:=Python
TITLE:=Core utilities for Python packages
URL:=https://github.com/pypa/packaging
- DEPENDS:=+python3-light +python3-pyparsing +python3-six +python3-logging +python3-distutils +python3-urllib
+ DEPENDS:=+python3-light +python3-logging +python3-urllib @BROKEN
endef
define Package/python3-packaging/description
@@ -35,6 +40,9 @@ define Package/python3-packaging/description
markers, requirements, tags, utilities.
endef
+Host/Compile=$(Py3Host/Compile/Bootstrap)
+
$(eval $(call Py3Package,python3-packaging))
$(eval $(call BuildPackage,python3-packaging))
$(eval $(call BuildPackage,python3-packaging-src))
+$(eval $(call HostBuild))