aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJavier Marcet <javier@marcet.info>2020-02-17 14:44:33 +0100
committerJavier Marcet <javier@marcet.info>2020-06-08 13:48:40 +0200
commitcbf50bb03c166cc0bff8c33ce7b2e94ed1b480ec (patch)
treeb48905623deb522ed4e39d1ec8ebcb0afc33e969 /lang/python
parent70fe482c410b00b81ee694c5dc9557438b21df42 (diff)
python3-cached-property: add a new package
Signed-off-by: Javier Marcet <javier@marcet.info>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python-cached-property/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/python/python-cached-property/Makefile b/lang/python/python-cached-property/Makefile
new file mode 100644
index 000000000..447b4054c
--- /dev/null
+++ b/lang/python/python-cached-property/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-cached-property
+PKG_VERSION:=1.5.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=cached-property
+PKG_HASH:=9217a59f14a5682da7c4b8829deadbfc194ac22e9908ccf7c8820234e80a1504
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+define Package/python3-cached-property
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=A decorator for caching properties in classes
+ URL:=https://github.com/pydanny/cached-property
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-cached-property/description
+ A decorator for caching properties in classes.
+endef
+
+$(eval $(call Py3Package,python3-cached-property))
+$(eval $(call BuildPackage,python3-cached-property))
+$(eval $(call BuildPackage,python3-cached-property-src))