aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <aa@ocedo.com>2014-10-17 16:34:12 +0300
committerAlexandru Ardelean <aa@ocedo.com>2014-10-17 16:34:15 +0300
commitaafbac886eb7ebcad876c1a49c8e085b059727e6 (patch)
treecedd41c1b3e7550daea1cfd6280c8c99c70f3465 /lang/python
parent09c02844e497998dde3850fe231a3cc2d42f8125 (diff)
python: patch setup.py so that it does not include system include dirs
Seems that the Python C extensions were being (or at least trying to be) build using '/usr/include' as the first include folder. Seems this issue was already fixed on MacOS X and now we've extended it for our case. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/patches/120-do-not-add-include-dirs-when-cross-compiling.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/lang/python/patches/120-do-not-add-include-dirs-when-cross-compiling.patch b/lang/python/patches/120-do-not-add-include-dirs-when-cross-compiling.patch
new file mode 100644
index 000000000..fb2fe8a77
--- /dev/null
+++ b/lang/python/patches/120-do-not-add-include-dirs-when-cross-compiling.patch
@@ -0,0 +1,14 @@
+diff --git a/setup.py b/setup.py
+index cbdeaf3..5154412 100644
+--- a/setup.py
++++ b/setup.py
+@@ -480,7 +480,8 @@ class PyBuildExt(build_ext):
+ add_dir_to_list(dir_list, directory)
+
+ if os.path.normpath(sys.prefix) != '/usr' \
+- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
++ and not sysconfig.get_config_var('PYTHONFRAMEWORK') \
++ and not cross_compiling:
+ # OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
+ # (PYTHONFRAMEWORK is set) to avoid # linking problems when
+ # building a framework with different architectures than