aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-02-25 21:21:53 +0800
committerJeffery To <jeffery.to@gmail.com>2023-03-31 13:06:34 +0800
commitaabe27a3793dab740a486611c656b56db68f95da (patch)
treef10a32f22f459e106a70923da118c3b82b8229a2 /lang/python
parent8f32fd202e2369ad5f8c33e45fb2d2f846613631 (diff)
python-cffi: Update to 1.15.1, add host build
The host build replaces the use of the host pip requirements file. This also updates the dependants of cffi to depend on the host build. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/bcrypt/Makefile5
-rw-r--r--lang/python/host-pip-requirements/cffi.txt2
-rw-r--r--lang/python/python-augeas/Makefile4
-rw-r--r--lang/python/python-cffi/Makefile18
-rw-r--r--lang/python/python-cryptography/Makefile8
-rw-r--r--lang/python/python-pycares/Makefile6
-rw-r--r--lang/python/python-pynacl/Makefile6
7 files changed, 25 insertions, 24 deletions
diff --git a/lang/python/bcrypt/Makefile b/lang/python/bcrypt/Makefile
index 62312343f..9e49ce333 100644
--- a/lang/python/bcrypt/Makefile
+++ b/lang/python/bcrypt/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=bcrypt
PKG_VERSION:=3.1.7
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=0b0069c752ec14172c5f78208f1863d7ad6755a6fae6fe76ec2c80d13be41e42
@@ -15,8 +15,7 @@ PKG_HASH:=0b0069c752ec14172c5f78208f1863d7ad6755a6fae6fe76ec2c80d13be41e42
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
-PKG_BUILD_DEPENDS:=libffi/host
-HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=cffi # cffi>=1.1
+PKG_BUILD_DEPENDS:=libffi/host python-cffi/host # cffi>=1.1
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/lang/python/host-pip-requirements/cffi.txt b/lang/python/host-pip-requirements/cffi.txt
deleted file mode 100644
index 94ef13b55..000000000
--- a/lang/python/host-pip-requirements/cffi.txt
+++ /dev/null
@@ -1,2 +0,0 @@
-cffi==1.15.0 --hash=sha256:920f0d66a896c2d99f0adbb391f990a84091179542c205fa53ce5787aff87954
-pycparser==2.21 --hash=sha256:e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206
diff --git a/lang/python/python-augeas/Makefile b/lang/python/python-augeas/Makefile
index dab2d5e91..e366d429b 100644
--- a/lang/python/python-augeas/Makefile
+++ b/lang/python/python-augeas/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-augeas
PKG_VERSION:=1.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=python-augeas
PKG_HASH:=5194a49e86b40ffc57055f73d833f87e39dce6fce934683e7d0d5bbb8eff3b8c
@@ -18,7 +18,7 @@ PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=COPYING
-HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=cffi # cffi>=1.0.0
+PKG_BUILD_DEPENDS:=python-cffi/host # cffi>=1.0.0
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/lang/python/python-cffi/Makefile b/lang/python/python-cffi/Makefile
index 41549e922..b14ef8099 100644
--- a/lang/python/python-cffi/Makefile
+++ b/lang/python/python-cffi/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015-2018 OpenWrt.org
+# Copyright (C) 2015-2016, 2018-2021, 2023 Jeffery To
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,19 +8,28 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-cffi
-PKG_VERSION:=1.15.0
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=1.15.1
+PKG_RELEASE:=1
PYPI_NAME:=cffi
-PKG_HASH:=920f0d66a896c2d99f0adbb391f990a84091179542c205fa53ce5787aff87954
+PKG_HASH:=d400bfb9a37b1351253cb402671cea7e89bdecc294e8016a707f6d1d8ac934f9
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+HOST_BUILD_DEPENDS:= \
+ python3/host \
+ python-build/host \
+ python-installer/host \
+ python-wheel/host \
+ python-pycparser/host
+
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
include ../python3-package.mk
+include ../python3-host-build.mk
define Package/python3-cffi
SECTION:=lang
@@ -41,3 +50,4 @@ endef
$(eval $(call Py3Package,python3-cffi))
$(eval $(call BuildPackage,python3-cffi))
$(eval $(call BuildPackage,python3-cffi-src))
+$(eval $(call HostBuild))
diff --git a/lang/python/python-cryptography/Makefile b/lang/python/python-cryptography/Makefile
index f9805d1b3..eca939458 100644
--- a/lang/python/python-cryptography/Makefile
+++ b/lang/python/python-cryptography/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015-2018 OpenWrt.org
+# Copyright (C) 2015-2016, 2018-2023 Jeffery To
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-cryptography
PKG_VERSION:=3.4.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PYPI_NAME:=cryptography
PKG_HASH:=94cc5ed4ceaefcbe5bf38c8fba6a21fc1d365bb8fb826ea1688e3370b2e24a1c
@@ -18,9 +18,7 @@ PKG_LICENSE:=Apache-2.0 BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.APACHE LICENSE.BSD
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
-PKG_BUILD_DEPENDS:=libffi/host
-
-HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=cffi # cffi>=1.12
+PKG_BUILD_DEPENDS:=libffi/host python-cffi/host # cffi>=1.12
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/lang/python/python-pycares/Makefile b/lang/python/python-pycares/Makefile
index 2eed1c2b1..c3516f73f 100644
--- a/lang/python/python-pycares/Makefile
+++ b/lang/python/python-pycares/Makefile
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-pycares
PKG_VERSION:=4.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=pycares
PKG_HASH:=c542696f6dac978e9d99192384745a65f80a7d9450501151e4a7563e06010d45
@@ -12,9 +12,7 @@ PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PKG_MAINTAINER:=Fabian Lipken <dynasticorpheus@gmail.com>
-PKG_BUILD_DEPENDS:=libffi/host
-
-HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=cffi # cffi>=1.5.0
+PKG_BUILD_DEPENDS:=libffi/host python-cffi/host # cffi>=1.5.0
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/lang/python/python-pynacl/Makefile b/lang/python/python-pynacl/Makefile
index 6635f4935..d3469cc43 100644
--- a/lang/python/python-pynacl/Makefile
+++ b/lang/python/python-pynacl/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-pynacl
PKG_VERSION:=1.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=PyNaCl
PKG_HASH:=8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba
@@ -11,9 +11,7 @@ PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
-PKG_BUILD_DEPENDS:=libffi/host
-
-HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=cffi # cffi>=1.4.1
+PKG_BUILD_DEPENDS:=libffi/host python-cffi/host # cffi>=1.4.1
PYTHON3_PKG_SETUP_VARS:= SODIUM_INSTALL=system