aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2014-11-09 21:08:06 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2014-11-09 21:08:08 +0200
commita91a992abb1fe9b7c4e4e5d11532dbf18c5b213d (patch)
treef683f01b0e0320e7af0872143ec7ed306d8db57b /lang/python
parent2c1bc16d2056a03578288877200772184a875687 (diff)
python: add __PYENV_LAUNCHER__ env var
Mostly useful for setuptools and pip during build. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/files/python-package.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/python/files/python-package.mk b/lang/python/files/python-package.mk
index 07f27197c..b9349f3c1 100644
--- a/lang/python/files/python-package.mk
+++ b/lang/python/files/python-package.mk
@@ -89,6 +89,7 @@ define Build/Compile/PyMod
CPPFLAGS="$(TARGET_CPPFLAGS) -I$(PYTHON_INC_DIR)" \
LDFLAGS="$(TARGET_LDFLAGS) -lpython$(PYTHON_VERSION)" \
_PYTHON_HOST_PLATFORM="linux-$(ARCH)" \
+ __PYVENV_LAUNCHER__="/usr/bin/$(PYTHON)" \
$(3) \
, \
./setup.py $(2) \