aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <aa@ocedo.com>2014-11-05 15:24:33 +0200
committerAlexandru Ardelean <aa@ocedo.com>2014-11-07 15:37:18 +0200
commit9e78aff7708a72e615dbc6fb139f6e1dd4767441 (patch)
treefb4f44581b44e372f1681b202ac73d83270cd4b6 /lang/python
parent242286b80d4db24dd42217b3d9a689bcdcfb020b (diff)
python: add PKG_USE_MIPS16:=0 + handle CONFIG_USE_MIPS16
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/files/python-package.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/python/files/python-package.mk b/lang/python/files/python-package.mk
index 3f714d27f..07f27197c 100644
--- a/lang/python/files/python-package.mk
+++ b/lang/python/files/python-package.mk
@@ -30,6 +30,13 @@ define HostPython
)
endef
+PKG_USE_MIPS16:=0
+# This is required in addition to PKG_USE_MIPS16:=0 because otherwise MIPS16
+# flags are inherited from the Python base package (via sysconfig module)
+ifdef CONFIG_USE_MIPS16
+ TARGET_CFLAGS += -mno-mips16 -mno-interlink-mips16
+endif
+
define PyPackage
$(call shexport,PyPackage/$(1)/filespec)