aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-25 11:58:12 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-11 15:50:23 +0800
commit9db7284d589dc8490f8c7dbe56af731fce953eda (patch)
treebd7329983710c19d0428ce89b358c7b41b59f87f /lang/python
parent853c9c9e8625c54a2c3214b2ef770ffc76bd3495 (diff)
rust: Consolidate cargo environment variables
This consolidates all environment variables for cargo into: * CARGO_HOST_CONFIG_VARS / CARGO_PKG_CONFIG_VARS These contain all cargo-specific environment variables, i.e. without "common" variables like CC. * CARGO_HOST_VARS / CARGO_PKG_VARS (renamed from CARGO_VARS) These contain all environment variables to be passed to cargo. This also: * Set the CARGO_BUILD_TARGET environment variable instead of using the --target command-line option * Update Python include files to use CARGO_HOST_CONFIG_VARS / CARGO_PKG_CONFIG_VARS Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python3-host.mk2
-rw-r--r--lang/python/python3-package.mk6
2 files changed, 3 insertions, 5 deletions
diff --git a/lang/python/python3-host.mk b/lang/python/python3-host.mk
index 6ca002587..b233c5679 100644
--- a/lang/python/python3-host.mk
+++ b/lang/python/python3-host.mk
@@ -78,7 +78,7 @@ HOST_PYTHON3_VARS = \
CFLAGS="$(HOST_CFLAGS)" \
CPPFLAGS="$(HOST_CPPFLAGS) -I$(HOST_PYTHON3_INC_DIR)" \
LDFLAGS="$(HOST_LDFLAGS) -lpython$(PYTHON3_VERSION) -Wl$(comma)-rpath$(comma)$(STAGING_DIR_HOSTPKG)/lib" \
- CARGO_HOME="$(CARGO_HOME)"
+ $(CARGO_HOST_CONFIG_VARS)
# $(1) => directory of python script
# $(2) => python script and its arguments
diff --git a/lang/python/python3-package.mk b/lang/python/python3-package.mk
index fcb1d06b3..e4c7bd264 100644
--- a/lang/python/python3-package.mk
+++ b/lang/python/python3-package.mk
@@ -45,10 +45,8 @@ PYTHON3_VARS = \
_python_sysroot="$(STAGING_DIR)" \
_python_prefix="/usr" \
_python_exec_prefix="/usr" \
- CARGO_BUILD_TARGET="$(RUSTC_TARGET_ARCH)" \
- CARGO_HOME="$(CARGO_HOME)" \
- PYO3_CROSS_LIB_DIR="$(PYTHON3_LIB_DIR)" \
- RUSTFLAGS="$(CARGO_RUSTFLAGS)"
+ $(CARGO_PKG_CONFIG_VARS) \
+ PYO3_CROSS_LIB_DIR="$(PYTHON3_LIB_DIR)"
# $(1) => directory of python script
# $(2) => python script and its arguments