aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2015-01-15 23:17:22 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2015-01-15 23:24:59 +0200
commit903432c91e48eda6c46bbeab76338b0dba45087a (patch)
tree3606bc486dd43ea8b8658abfceec84b3e343222d /lang/python
parent1c40fc1022377e565b037df92391b2b5ade110c8 (diff)
python: add patch to remove Debian/Ubuntu multiarch support
Seems when cross compiling on x86_64 Debian (most likely Ubuntu too) the host's paths will be added too causing build failures for some extensions. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/patches/160-remove-debian-multiarch-support.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/lang/python/patches/160-remove-debian-multiarch-support.patch b/lang/python/patches/160-remove-debian-multiarch-support.patch
new file mode 100644
index 000000000..52d52b94e
--- /dev/null
+++ b/lang/python/patches/160-remove-debian-multiarch-support.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 7868b7b..9ae0ef2 100644
+--- a/setup.py
++++ b/setup.py
+@@ -444,7 +444,6 @@ class PyBuildExt(build_ext):
+ add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+ if cross_compiling:
+ self.add_gcc_paths()
+- self.add_multiarch_paths()
+
+ # Add paths specified in the environment variables LDFLAGS and
+ # CPPFLAGS for header and library files.