aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-10-09 09:21:58 +0800
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2023-10-11 09:09:31 +0200
commit7e8f7b28d74ca2044309dff9c789dec055ee43c5 (patch)
tree189cb17752a8c68dc5bacc1f5271b50d520b9c8b /lang/python
parentaf7a15c905782ff685aa8021197c37ce3d3e71b4 (diff)
python-zope-interface: Update to 6.1, refresh patch
This also updates the list of dependencies and adds a test.sh script for the packages feed CI. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python-zope-interface/Makefile6
-rw-r--r--lang/python/python-zope-interface/patches/001-omit-tests.patch4
-rw-r--r--lang/python/python-zope-interface/test.sh5
3 files changed, 10 insertions, 5 deletions
diff --git a/lang/python/python-zope-interface/Makefile b/lang/python/python-zope-interface/Makefile
index d1fb831d0..81eac63f9 100644
--- a/lang/python/python-zope-interface/Makefile
+++ b/lang/python/python-zope-interface/Makefile
@@ -9,11 +9,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-zope-interface
-PKG_VERSION:=6.0
+PKG_VERSION:=6.1
PKG_RELEASE:=1
PYPI_NAME:=zope.interface
-PKG_HASH:=aab584725afd10c710b8f1e6e208dbee2d0ad009f57d674cb9d1b3964037275d
+PKG_HASH:=2fdc7ccbd6eb6b7df5353012fbed6c3c5d04ceaca0038f75e601060e95345309
PKG_LICENSE:=ZPL-2.1
PKG_LICENSE_FILES:=LICENSE.txt
@@ -29,7 +29,7 @@ define Package/python3-zope-interface
SUBMENU:=Python
TITLE:=Interfaces for Python
URL:=https://github.com/zopefoundation/zope.interface
- DEPENDS:=+python3-light
+ DEPENDS:=+python3-light +python3-logging
endef
define Package/python3-zope-interface/description
diff --git a/lang/python/python-zope-interface/patches/001-omit-tests.patch b/lang/python/python-zope-interface/patches/001-omit-tests.patch
index 364ae216f..40aed6e2b 100644
--- a/lang/python/python-zope-interface/patches/001-omit-tests.patch
+++ b/lang/python/python-zope-interface/patches/001-omit-tests.patch
@@ -1,6 +1,6 @@
--- a/setup.py
+++ b/setup.py
-@@ -124,7 +124,7 @@ setup(name='zope.interface',
+@@ -125,7 +125,7 @@ setup(name='zope.interface',
"Framework :: Zope :: 3",
"Topic :: Software Development :: Libraries :: Python Modules",
],
@@ -9,7 +9,7 @@
package_dir={'': 'src'},
namespace_packages=["zope"],
cmdclass={
-@@ -132,6 +132,7 @@ setup(name='zope.interface',
+@@ -133,6 +133,7 @@ setup(name='zope.interface',
},
test_suite='zope.interface.tests',
include_package_data=True,
diff --git a/lang/python/python-zope-interface/test.sh b/lang/python/python-zope-interface/test.sh
new file mode 100644
index 000000000..48123771c
--- /dev/null
+++ b/lang/python/python-zope-interface/test.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+[ "$1" = python3-zope-interface ] || exit 0
+
+python3 -c 'import zope.interface'