aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-10-14 01:51:09 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-14 01:51:09 +0800
commit783e6f7491b8fd4f5c9d82a63fef324a52f94923 (patch)
tree375f7b6dadd33650ea5ff1e713e5a8eed4a10b41 /lang/python
parent8c5f98d9524cc124bbbd02ffd95e37ef5283f8c8 (diff)
maturin: Update to 1.3.0, build as Python (host-only) package
Python packages that use maturin to build do not call the maturin program directly; they use the maturin build backend[1]. This build backend is a Python library provided with maturin that interfaces with the maturin program. This changes the maturin package to use the Python build process so that the build backend is installed correctly. This also renames the source package to python-maturin and moves it into the lang/python directory. [1]: https://www.maturin.rs/#source-distribution Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python-maturin/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/lang/python/python-maturin/Makefile b/lang/python/python-maturin/Makefile
new file mode 100644
index 000000000..67bb1e0ab
--- /dev/null
+++ b/lang/python/python-maturin/Makefile
@@ -0,0 +1,51 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2023 Luca Barbato
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-maturin
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=maturin
+PKG_HASH:=f6c69bc7ae147a5effd55587447b35cab1ceb726ba244d08698bc7518b8688ac
+
+PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
+PKG_LICENSE:=Apache-2.0 MIT
+PKG_LICENSE_FILES:=license-apache license-mit
+
+HOST_BUILD_DEPENDS:= \
+ python3/host \
+ python-build/host \
+ python-installer/host \
+ python-wheel/host \
+ python-setuptools-rust/host
+HOST_BUILD_PARALLEL:=1
+PKG_HOST_ONLY:=1
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-maturin
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Build and publish crates as python packages
+ DEPENDS:=$(RUST_ARCH_DEPENDS)
+ URL:=https://maturin.rs
+ BUILDONLY:=1
+endef
+
+define Package/python3-maturin/description
+ Build and publish crates with pyo3, rust-cpython, cffi and uniffi
+ bindings as well as rust binaries as python packages.
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call Py3Package,python3-maturin))
+$(eval $(call BuildPackage,python3-maturin))
+$(eval $(call BuildPackage,python3-maturin-src))