aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-01-10 03:28:31 +0100
committerAlexandru Ardelean <ardeleanalex@gmail.com>2018-01-10 23:01:51 +0200
commit55c0b5ae19afa8d160c6ccf10869c22fd3bd0c03 (patch)
tree95c9d4c57a99ba5cc6558fed65b882d6dd6f0587 /lang/python
parentc6b24960cd0fef5b66f7dee19cb25788fd70c102 (diff)
python,python3: do not install .mk snippets
The .mk snippets are not really usable at the moment, as they cannot be considered for metadata collection (package DUMP) when included through include_mk. Python packages do not use include_mk anymore for this reason, so the install commands can be removed as well. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python/Makefile12
-rw-r--r--lang/python/python3/Makefile12
2 files changed, 0 insertions, 24 deletions
diff --git a/lang/python/python/Makefile b/lang/python/python/Makefile
index e7500f66d..3c7b3bf6c 100644
--- a/lang/python/python/Makefile
+++ b/lang/python/python/Makefile
@@ -190,16 +190,6 @@ define Build/Compile
$(call Build/Compile/python-pip)
endef
-define Build/InstallMkFiles
- $(INSTALL_DIR) $(STAGING_DIR)/mk/
- $(INSTALL_DATA) \
- ./files/python-package.mk \
- ./files/python-host.mk \
- ./files/python-version.mk \
- ./files/python-package-install.sh \
- $(STAGING_DIR)/mk/
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/ $(1)/usr/lib/ $(1)/usr/lib/pkgconfig
$(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)/
@@ -218,7 +208,6 @@ define Build/InstallDev
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config \
$(1)/usr/lib/python$(PYTHON_VERSION)/
- $(call Build/InstallMkFiles)
endef
PYTHON_BASE_LIB_FILES:= \
@@ -298,7 +287,6 @@ define Host/Compile
endef
define Host/Install
- $(call Build/InstallMkFiles)
$(MAKE) -C $(HOST_BUILD_DIR) install
$(INSTALL_DIR) $(HOST_PYTHON_DIR)/bin/
$(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(HOST_PYTHON_DIR)/bin/pgen2
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 7ab3c51da..6c293ef4d 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -194,16 +194,6 @@ define Build/Compile
$(call Build/Compile/python3-pip)
endef
-define Build/InstallMkFiles
- $(INSTALL_DIR) $(STAGING_DIR)/mk/
- $(INSTALL_DATA) \
- ./files/python3-package.mk \
- ./files/python3-host.mk \
- ./files/python3-version.mk \
- ./files/python3-package-install.sh \
- $(STAGING_DIR)/mk/
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/ $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)/
@@ -217,7 +207,6 @@ define Build/InstallDev
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config-$(PYTHON_VERSION) \
$(1)/usr/lib/python$(PYTHON_VERSION)/
- $(call Build/InstallMkFiles)
endef
PYTHON3_BASE_LIB_FILES:= \
@@ -295,7 +284,6 @@ define Host/Compile
endef
define Host/Install
- $(call Build/InstallMkFiles)
$(MAKE) -C $(HOST_BUILD_DIR) install
$(INSTALL_DIR) $(HOST_PYTHON3_DIR)/bin/
$(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(HOST_PYTHON3_DIR)/bin/pgen3