aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-23 00:02:01 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-11 15:50:22 +0800
commit49aaf19c65a35c37725ead7a438684411b512d6f (patch)
treea7fa4db8ac92355a1e81e3557d370b4d9217365a /lang/python
parent855623d8cce4db8655af58bed5d52c64d38608c5 (diff)
rust: Install to $(STAGING_DIR)/host
This allows rustc/cargo/etc to be called without having to set PATH, as $(STAGING_DIR)/host/bin is already in PATH. This also fixes CARGO_HOME not being set during Host/Configure and Host/Compile. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python3-host.mk3
-rw-r--r--lang/python/python3-package.mk1
2 files changed, 1 insertions, 3 deletions
diff --git a/lang/python/python3-host.mk b/lang/python/python3-host.mk
index ca5cb64ba..6ca002587 100644
--- a/lang/python/python3-host.mk
+++ b/lang/python/python3-host.mk
@@ -78,8 +78,7 @@ HOST_PYTHON3_VARS = \
CFLAGS="$(HOST_CFLAGS)" \
CPPFLAGS="$(HOST_CPPFLAGS) -I$(HOST_PYTHON3_INC_DIR)" \
LDFLAGS="$(HOST_LDFLAGS) -lpython$(PYTHON3_VERSION) -Wl$(comma)-rpath$(comma)$(STAGING_DIR_HOSTPKG)/lib" \
- CARGO_HOME="$(CARGO_HOME)" \
- PATH="$(CARGO_HOME)/bin:$(PATH)"
+ CARGO_HOME="$(CARGO_HOME)"
# $(1) => directory of python script
# $(2) => python script and its arguments
diff --git a/lang/python/python3-package.mk b/lang/python/python3-package.mk
index 0693d21ee..fcb1d06b3 100644
--- a/lang/python/python3-package.mk
+++ b/lang/python/python3-package.mk
@@ -47,7 +47,6 @@ PYTHON3_VARS = \
_python_exec_prefix="/usr" \
CARGO_BUILD_TARGET="$(RUSTC_TARGET_ARCH)" \
CARGO_HOME="$(CARGO_HOME)" \
- PATH="$(CARGO_HOME)/bin:$(PATH)" \
PYO3_CROSS_LIB_DIR="$(PYTHON3_LIB_DIR)" \
RUSTFLAGS="$(CARGO_RUSTFLAGS)"