aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2020-04-17 11:40:30 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2020-05-27 11:14:55 +0300
commit43403ccb4682a314b9be37aed1bbcf43b70f9afe (patch)
treeeaeb77de1d9a474b02119b9da394bd76df620b16 /lang/python
parent852c117c60f7ec8b36bcd02e3f79901f7143dde0 (diff)
python-lxml: bump to version 4.5.1
This took a while to get running. It turns out, the fix is mostly in libxslt. lxml uses the xsltGetProfileInformation() function, which is disabled from libxslt via --without-profiler. This causes a runtime error, since it cannot find the symbol. So, libxslt is also updated to re-enable the profiler. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python-lxml/Makefile17
1 files changed, 3 insertions, 14 deletions
diff --git a/lang/python/python-lxml/Makefile b/lang/python/python-lxml/Makefile
index 3b9fe00d8..0c38979a3 100644
--- a/lang/python/python-lxml/Makefile
+++ b/lang/python/python-lxml/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-lxml
-PKG_VERSION:=4.4.2
-PKG_RELEASE:=3
+PKG_VERSION:=4.5.1
+PKG_RELEASE:=1
PYPI_NAME:=lxml
-PKG_HASH:=eff69ddbf3ad86375c344339371168640951c302450c5d3e9936e98d6459db06
+PKG_HASH:=27ee0faf8077c7c1a589573b1450743011117f1aa1a91d5ae776bbc5ca6070f2
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSES.txt
@@ -41,17 +41,6 @@ define Package/python3-lxml/description
XPath, RelaxNG, XML Schema, XSLT, C14N and much more.
endef
-TARGET_LDFLAGS += -lxml2 -lxslt -lexslt
-
-PYTHON3_PKG_SETUP_ARGS += \
- --static
-
-PYTHON3_PKG_SETUP_VARS += \
- INCLUDE="$(STAGING_DIR)/usr/include/ $(STAGING_DIR)/usr/include/libxml2" \
- LIBRARY="$(STAGING_DIR)/usr/lib $(STAGING_DIR)/lib" \
- CFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)"
-
$(eval $(call Py3Package,python3-lxml))
$(eval $(call BuildPackage,python3-lxml))
$(eval $(call BuildPackage,python3-lxml-src))