aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <alex@shruggie.ro>2023-10-06 09:34:00 +0300
committerGitHub <noreply@github.com>2023-10-06 09:34:00 +0300
commit3b9abf783694fea1b087755ef6fa64938b40a751 (patch)
treeb0eef49ac8cda8c1750068c2e73b476a5aff90ba /lang/python
parent72d2a784876aaf76be8dff8120cd233f208e5f7c (diff)
parent79b173a0c5e7cbb610a510ab759af1de488196c5 (diff)
Merge pull request #22301 from cotequeiroz/pymysql_sha256
pymysql: add meta-package for sha256 support
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/pymysql/Config.in11
-rw-r--r--lang/python/pymysql/Makefile27
2 files changed, 22 insertions, 16 deletions
diff --git a/lang/python/pymysql/Config.in b/lang/python/pymysql/Config.in
deleted file mode 100644
index 0dfa265b0..000000000
--- a/lang/python/pymysql/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-menu "Configuration"
- depends on PACKAGE_python3-pymysql
-
-config PYTHON3_PYMYSQL_SHA_PASSWORD_SUPPORT
- bool "Enable support for SHA password authentication"
- help
- To use “sha256_password” or “caching_sha2_password” for authentication
- this symbol needs to be enabled, to also install python3-cryptography.
- default n
-
-endmenu
diff --git a/lang/python/pymysql/Makefile b/lang/python/pymysql/Makefile
index d5187bd57..025a97adc 100644
--- a/lang/python/pymysql/Makefile
+++ b/lang/python/pymysql/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pymysql
PKG_VERSION:=1.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=PyMySQL
PKG_HASH:=4f13a7df8bf36a51e81dd9f3605fede45a4878fe02f9236349fd82a3f0612f96
@@ -24,23 +24,40 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python3-pymysql
+define Package/python3-pymysql/Default
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=Pure Python MySQL Client
URL:=https://pymysql.readthedocs.io/
- DEPENDS:=+python3 +PYTHON3_PYMYSQL_SHA_PASSWORD_SUPPORT:python3-cryptography
endef
-define Package/python3-pymysql/config
- source "$(SOURCE)/Config.in"
+define Package/python3-pymysql
+$(call Package/python3-pymysql/Default)
+ DEPENDS:=+python3
endef
define Package/python3-pymysql/description
This package contains a pure-Python MySQL client library, based on PEP 249.
endef
+define Package/python3-pymysql-sha-pwd
+$(call Package/python3-pymysql/Default)
+ TITLE+=w/ SHA256 password auth
+ DEPENDS:=+python3-pymysql $(RUST_ARCH_DEPENDS) +PACKAGE_python3-pymysql-sha-pwd:python3-cryptography
+endef
+
+define Package/python3-pymysql-sha-pwd/description
+ This is a meta-package installing python3-pymysql and python3-cryptography
+ packages to be able to use pymysql with “sha256_password” or
+ “caching_sha2_password” for authentication.
+endef
+
+define Package/python3-pymysql-sha-pwd/install
+ true
+endef
+
$(eval $(call Py3Package,python3-pymysql))
$(eval $(call BuildPackage,python3-pymysql))
$(eval $(call BuildPackage,python3-pymysql-src))
+$(eval $(call BuildPackage,python3-pymysql-sha-pwd))