aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2014-11-04 23:02:53 +0200
committerAlexandru Ardelean <aa@ocedo.com>2014-11-07 15:37:17 +0200
commit38a72bab1fee9683f7722a55de85444b3df1ae5a (patch)
tree8677ec3ecf22fb5e90de15a350bb63f05b60ac74 /lang/python
parent7a689890eba6bf76909462e22e5135c7934105c0 (diff)
python: cleanup Build/InstallDev rule
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile16
1 files changed, 0 insertions, 16 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 4eb39463d..3f2d30ab0 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -106,24 +106,8 @@ Hooks/Configure/Pre+=\
Hooks/Configure/Pre/ConfigSiteInstall
define Build/InstallDev
- $(INSTALL_DIR) $(2)/bin $(1)/usr/bin $(1)/usr/include $(1)/usr/lib
$(INSTALL_DIR) $(STAGING_DIR)/mk/
$(INSTALL_DATA) ./files/python-package.mk $(STAGING_DIR)/mk/
- $(CP) \
- $(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
- $(1)/usr/include/
- $(CP) \
- $(STAGING_DIR_HOST)/lib/python$(PYTHON_VERSION) \
- $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
- $(1)/usr/lib/
- $(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config \
- $(1)/usr/lib/python$(PYTHON_VERSION)/
-
- $(CP) \
- $(STAGING_DIR_HOST)/bin/python$(PYTHON_VERSION)-config \
- $(2)/bin/
- $(SED) 's,^#!.*,#!/usr/bin/env python$(PYTHON_VERSION),g' $(2)/bin/python$(PYTHON_VERSION)-config
endef
define PyPackage/python/filespec