aboutsummaryrefslogtreecommitdiff
path: root/lang/python/vobject
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-21 03:03:12 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-30 23:16:18 +0800
commit635cb1309c4d52763c03bc00e7c367e06908b54f (patch)
treef4ab5d3c372741d39b2c0c9e9e34a0c007ca6d53 /lang/python/vobject
parent29ef2938d131ad862f28c2e6f09656351a4ca006 (diff)
treewide: Use pypi.mk for Python packages
This updates all Python packages that download their source from PyPi to use pypi.mk. This will allow future improvements/changes to pypi.mk to affect all relevant packages. This also makes it easier for future Python packages to start using pypi.mk, when it's clear how it is used in existing packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/vobject')
-rw-r--r--lang/python/vobject/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/lang/python/vobject/Makefile b/lang/python/vobject/Makefile
index 3aa345b06..49e81e143 100644
--- a/lang/python/vobject/Makefile
+++ b/lang/python/vobject/Makefile
@@ -8,18 +8,15 @@ PKG_VERSION:=0.9.6.1
PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/v/vobject
+PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=96512aec74b90abb71f6b53898dd7fe47300cc940104c4f79148f0671f790101
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-vobject-$(PKG_VERSION)
+include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
include ../python3-package.mk
-PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
-
define Package/python-vobject/Default
SUBMENU:=Python
SECTION:=lang