aboutsummaryrefslogtreecommitdiff
path: root/lang/python/vobject
diff options
context:
space:
mode:
authorDaniel F. Dickinson <cshored@thecshore.com>2019-01-01 03:14:48 -0500
committerDaniel F. Dickinson <cshored@thecshore.com>2019-01-07 07:33:00 -0500
commit624a3f5fc0c39292af8bc8b2a4f6a001239e8803 (patch)
treec3f5da88a5118d1a47d1101ff21e823864bb718e /lang/python/vobject
parent483c9fceae100dd7c205c614a35907ecc9496965 (diff)
vobject: Add python library
Lbrary for vCard and vCalendar support for Python{3}. vobject is used by Radicale2 so add it. Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
Diffstat (limited to 'lang/python/vobject')
-rw-r--r--lang/python/vobject/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/lang/python/vobject/Makefile b/lang/python/vobject/Makefile
new file mode 100644
index 000000000..3aa345b06
--- /dev/null
+++ b/lang/python/vobject/Makefile
@@ -0,0 +1,59 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vobject
+PKG_VERSION:=0.9.6.1
+PKG_RELEASE:=1
+PKG_LICENSE:=Apache-2.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/v/vobject
+PKG_HASH:=96512aec74b90abb71f6b53898dd7fe47300cc940104c4f79148f0671f790101
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-vobject-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+include ../python-package.mk
+include ../python3-package.mk
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
+define Package/python-vobject/Default
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ MAINTAINER:=Daniel Dickinson <cshored@thecshore.com>
+ TITLE:=VObject
+ URL:=http://eventable.github.io/vobject/
+endef
+
+define Package/python-vobject
+$(call Package/python-vobject/Default)
+ DEPENDS:=+PACKAGE_python-vobject:python +PACKAGE_python-vobject:python-dateutil
+ VARIANT:=python
+endef
+
+define Package/python3-vobject
+$(call Package/python-vobject/Default)
+ DEPENDS:=+PACKAGE_python3-vobject:python3 +PACKAGE_python3-vobject:python3-dateutil
+ VARIANT:=python3
+endef
+
+define Package/python-vobject/description
+ vCard and vCalendar support for Python
+endef
+
+define Package/python3-vobject/description
+$(call Package/python-vobject/description)
+.
+(Variant for Python3)
+endef
+
+$(eval $(call PyPackage,python-vobject))
+$(eval $(call BuildPackage,python-vobject))
+$(eval $(call BuildPackage,python-vobject-src))
+$(eval $(call Py3Package,python3-vobject))
+$(eval $(call BuildPackage,python3-vobject))
+$(eval $(call BuildPackage,python3-vobject-src))