aboutsummaryrefslogtreecommitdiff
path: root/lang/python/vobject
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/vobject
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/vobject')
-rw-r--r--lang/python/vobject/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/lang/python/vobject/Makefile b/lang/python/vobject/Makefile
index 7afdd59c0..1bd27c12c 100644
--- a/lang/python/vobject/Makefile
+++ b/lang/python/vobject/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=vobject
PKG_VERSION:=0.9.6.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=Apache-2.0
PYPI_NAME:=$(PKG_NAME)
@@ -16,25 +16,18 @@ include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python-vobject/Default
+define Package/python3-vobject
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
MAINTAINER:=Daniel Dickinson <cshored@thecshore.com>
TITLE:=VObject
URL:=http://eventable.github.io/vobject/
-endef
-
-define Package/python3-vobject
-$(call Package/python-vobject/Default)
- DEPENDS:=+PACKAGE_python3-vobject:python3 +PACKAGE_python3-vobject:python3-dateutil
- VARIANT:=python3
+ DEPENDS:=+python3 +python3-dateutil
endef
define Package/python3-vobject/description
vCard and vCalendar support for Python
-.
-(Variant for Python3)
endef
$(eval $(call Py3Package,python3-vobject))