aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python3
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-05 11:53:41 +0800
committerTianling Shen <cnsztl@gmail.com>2023-09-08 19:01:47 +0800
commite42c8450393a317ab6df39f6e01411722872fd6b (patch)
treef424dbc7e22ef93bb4d66e309f22e629991196ba /lang/python/python3
parent106304c988fddf0b66220a7ca04bbf2902719616 (diff)
python3: Update to 3.11.5, refresh patches
Includes fix for CVE-2023-40217 (Bypass TLS handshake on closed sockets). This also: * Remove 027-install-python3-symlink-after-stdlib.patch This was merged upstream in https://github.com/python/cpython/pull/104693. * Remove fix for unnecessary linking with libbsd (60bf01cb606344619e002901646171da1e69c0f9) This was fixed upstream in https://github.com/python/cpython/pull/105236. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python3')
-rw-r--r--lang/python/python3/Makefile11
-rw-r--r--lang/python/python3/patches/003-do-not-run-compileall.patch4
-rw-r--r--lang/python/python3/patches/025-choose-python-config-version.patch2
-rw-r--r--lang/python/python3/patches/026-openssl-feature-flags.patch2
-rw-r--r--lang/python/python3/patches/027-install-python3-symlink-after-stdlib.patch11
-rw-r--r--lang/python/python3/test.sh7
6 files changed, 14 insertions, 23 deletions
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 0b4eb3159..a54d02704 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -11,15 +11,15 @@ include $(TOPDIR)/rules.mk
include ../python3-version.mk
PKG_NAME:=python3
-PKG_RELEASE:=3
+PKG_RELEASE:=1
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
-PKG_HASH:=2f0e409df2ab57aa9fc4cbddfb976af44e4e55bf6f619eee6bc5c2297264a7f6
+PKG_HASH:=85cd12e9cf1d6d5a45f17f7afe1cebe7ee628d3282281c492e86adf636defa3f
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
-PKG_LICENSE:=PSF-2.0
+PKG_LICENSE:=Python-2.0.1 0BSD
PKG_LICENSE_FILES:=LICENSE Doc/copyright.rst Doc/license.rst Modules/_ctypes/darwin/LICENSE Modules/_ctypes/libffi_osx/LICENSE Modules/expat/COPYING
PKG_CPE_ID:=cpe:/a:python:python
@@ -162,11 +162,6 @@ CONFIGURE_VARS += \
ac_cv_file__dev_ptc=no \
ac_cv_file__dev_ptmx=yes
-# Do not link with libbsd for flock
-# https://github.com/openwrt/packages/issues/21161
-CONFIGURE_VARS += \
- ac_cv_lib_bsd_flock=no
-
# Disable stdlib modules
# Check for a better way in the future: https://github.com/python/cpython/issues/98558
CONFIGURE_VARS += \
diff --git a/lang/python/python3/patches/003-do-not-run-compileall.patch b/lang/python/python3/patches/003-do-not-run-compileall.patch
index 9b6bc45a3..9bb10fac7 100644
--- a/lang/python/python3/patches/003-do-not-run-compileall.patch
+++ b/lang/python/python3/patches/003-do-not-run-compileall.patch
@@ -1,6 +1,6 @@
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -2118,6 +2118,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
+@@ -2123,6 +2123,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
fi
@@ -8,7 +8,7 @@
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
-j0 -d $(LIBDEST) -f \
-@@ -2145,6 +2146,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
+@@ -2150,6 +2151,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
-j0 -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
diff --git a/lang/python/python3/patches/025-choose-python-config-version.patch b/lang/python/python3/patches/025-choose-python-config-version.patch
index a8c06a726..aa56d8942 100644
--- a/lang/python/python3/patches/025-choose-python-config-version.patch
+++ b/lang/python/python3/patches/025-choose-python-config-version.patch
@@ -1,6 +1,6 @@
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -2163,7 +2163,7 @@ python-config: $(srcdir)/Misc/python-con
+@@ -2168,7 +2168,7 @@ python-config: $(srcdir)/Misc/python-con
@ # On Darwin, always use the python version of the script, the shell
@ # version doesn't use the compiler customizations that are provided
@ # in python (_osx_support.py).
diff --git a/lang/python/python3/patches/026-openssl-feature-flags.patch b/lang/python/python3/patches/026-openssl-feature-flags.patch
index 2546048b0..604f41d8e 100644
--- a/lang/python/python3/patches/026-openssl-feature-flags.patch
+++ b/lang/python/python3/patches/026-openssl-feature-flags.patch
@@ -47,7 +47,7 @@
PY_HASH_ENTRY(NULL, NULL, NULL, 0),
};
-@@ -873,11 +889,15 @@ py_evp_fromname(PyObject *module, const
+@@ -874,11 +890,15 @@ py_evp_fromname(PyObject *module, const
goto exit;
}
diff --git a/lang/python/python3/patches/027-install-python3-symlink-after-stdlib.patch b/lang/python/python3/patches/027-install-python3-symlink-after-stdlib.patch
deleted file mode 100644
index 26241d03e..000000000
--- a/lang/python/python3/patches/027-install-python3-symlink-after-stdlib.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile.pre.in
-+++ b/Makefile.pre.in
-@@ -1839,7 +1839,7 @@ altbininstall: $(BUILDPYTHON) @FRAMEWORK
- $(DESTDIR)$(BINDIR)/python$(VERSION)$(EXE); \
- fi
-
--bininstall: altbininstall
-+bininstall: commoninstall altbininstall
- if test ! -d $(DESTDIR)$(LIBPC); then \
- echo "Creating directory $(LIBPC)"; \
- $(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC); \
diff --git a/lang/python/python3/test.sh b/lang/python/python3/test.sh
new file mode 100644
index 000000000..b45e65414
--- /dev/null
+++ b/lang/python/python3/test.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+case "$1" in
+python3|python3-base|python3-light)
+ python3 --version | grep -Fx "Python $2"
+ ;;
+esac