aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python3
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-05-18 01:02:13 +0800
committerJeffery To <jeffery.to@gmail.com>2023-05-26 22:01:41 +0800
commitd53475ac21cf79bef902b61fac69ffe25a3aad2f (patch)
tree38c0f1e65e62f0169ffbfecc92584920b9609be3 /lang/python/python3
parent2aca3fee4b32337e5e906871a6a046b5a03c7ca9 (diff)
python3: Split venv module from python3-light into separate package
This adds a new subpackage for the venv module. This also moves the ensurepip module from python3-pip into python3-venv, as ensurepip is not necessary for pip but often used for venv. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python3')
-rw-r--r--lang/python/python3/Makefile2
-rw-r--r--lang/python/python3/files/python3-package-pip.mk1
-rw-r--r--lang/python/python3/files/python3-package-venv.mk19
3 files changed, 20 insertions, 2 deletions
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 020d88a6e..8d81bc3f8 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
include ../python3-version.mk
PKG_NAME:=python3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
diff --git a/lang/python/python3/files/python3-package-pip.mk b/lang/python/python3/files/python3-package-pip.mk
index 61ea48022..8b547cee8 100644
--- a/lang/python/python3/files/python3-package-pip.mk
+++ b/lang/python/python3/files/python3-package-pip.mk
@@ -29,7 +29,6 @@ define Py3Package/python3-pip/install
endef
$(eval $(call Py3BasePackage,python3-pip, \
- /usr/lib/python$(PYTHON3_VERSION)/ensurepip \
, \
DO_NOT_ADD_TO_PACKAGE_DEPENDS \
))
diff --git a/lang/python/python3/files/python3-package-venv.mk b/lang/python/python3/files/python3-package-venv.mk
new file mode 100644
index 000000000..b2ddcab79
--- /dev/null
+++ b/lang/python/python3/files/python3-package-venv.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Package/python3-venv
+$(call Package/python3/Default)
+ TITLE:=Python $(PYTHON3_VERSION) venv module
+ DEPENDS:=+python3
+endef
+
+$(eval $(call Py3BasePackage,python3-venv, \
+ /usr/lib/python$(PYTHON3_VERSION)/ensurepip \
+ /usr/lib/python$(PYTHON3_VERSION)/venv \
+ , \
+ DO_NOT_ADD_TO_PACKAGE_DEPENDS \
+))