aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python3
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2023-10-04 16:19:07 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2023-10-04 16:52:27 -0300
commitc230d7bd7f8a794032d2414588f1cdfc1a5ec74e (patch)
treee3fd1c62749434a5102c7f75f1dafb1950e20d3b /lang/python/python3
parent4dd49d7c3cd571107958154f1ed1ec8d8dba7464 (diff)
python3: avoid unnecessary rebuilds
Move the order in which BuildPackage is called, so that the libpython package is built ahead of the module packages, to avoid forcing a clean-build of the package when 'make package/python3/compile' is called a second time without changes. The library must be built first, so that when the buildsystem checks for ABI version changes using libpython3.version, its timestamp should be older than the dependent package's STAMP_PREPARED file. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'lang/python/python3')
-rw-r--r--lang/python/python3/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index a54d02704..14915715b 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -358,12 +358,6 @@ endef
$(eval $(call HostBuild))
-$(foreach package, $(PYTHON3_PACKAGES), \
- $(eval $(call Py3Package,$(package))) \
- $(eval $(call BuildPackage,$(package))) \
- $(eval $(call BuildPackage,$(package)-src)) \
-)
-
$(eval $(call BuildPackage,libpython3))
$(eval $(call BuildPackage,python3))
@@ -375,3 +369,9 @@ $(eval $(call BuildPackage,python3-light))
$(eval $(call BuildPackage,python3-base-src))
$(eval $(call BuildPackage,python3-light-src))
+
+$(foreach package, $(PYTHON3_PACKAGES), \
+ $(eval $(call Py3Package,$(package))) \
+ $(eval $(call BuildPackage,$(package))) \
+ $(eval $(call BuildPackage,$(package)-src)) \
+)