aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python3
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-07-03 22:34:48 +0800
committerJeffery To <jeffery.to@gmail.com>2023-08-25 01:47:42 +0800
commit87631ecdd4ece794ae600d35e259cc1227795313 (patch)
tree78a9ac222b9ebe8905b69c3937ce916f8e250003 /lang/python/python3
parent09e06f959414ae968a2a6fd2ef9ffd182009a94b (diff)
python3: Use regular package recipes for python3 package
There is no need to use Py3Package for python3 as it does not package any Python files; it is an empty package with dependencies to install the full Python installation. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python3')
-rw-r--r--lang/python/python3/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 58ea2e0e0..0d9e25405 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -264,11 +264,7 @@ define Py3Package/python3-base/install
endef
Py3Package/python3-light/install:=:
-Py3Package/python3/install:=:
-
-define Py3Package/python3/filespec
--|$(PYTHON3_PKG_DIR)
-endef
+Package/python3/install:=:
# libuuid is provided by e2fsprogs and uuid/uuid.h is moved into
# $(STAGING_DIR_HOST)/include/e2fsprogs
@@ -351,14 +347,13 @@ $(foreach package, $(PYTHON3_PACKAGES), \
)
$(eval $(call BuildPackage,libpython3))
+$(eval $(call BuildPackage,python3))
$(eval $(call Py3Package,python3-base))
$(eval $(call Py3Package,python3-light))
-$(eval $(call Py3Package,python3))
$(eval $(call BuildPackage,python3-base))
$(eval $(call BuildPackage,python3-light))
-$(eval $(call BuildPackage,python3))
$(eval $(call BuildPackage,python3-base-src))
$(eval $(call BuildPackage,python3-light-src))