aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python3
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2021-05-19 12:16:20 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2021-05-19 14:17:00 +0300
commit49faf5d7cacf91aeb0c72447f0f5a069c891c3a9 (patch)
treea73488fe0692080f98673d9c00db6eac64cbb836 /lang/python/python3
parent35264e0a2c2a6f231264ce9c6ebf280a5bd2d35d (diff)
python3: add python3-readline subpackage
Python3 comes with a built-in readline module. It wasn't included up until now; mostly because it wasn't considered. This change introduces it as a sub-package of the main Python3 package. readline support is included in Python. libreadline pulls libncursesw as a package, so python3-ncurses was updated to pull libncursesw as well. It should be the same package; mostly done for consistency. Resolves the issue reported here: https://forum.openwrt.org/t/python3-repl-missing-readline/90039 Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python/python3')
-rw-r--r--lang/python/python3/Makefile3
-rw-r--r--lang/python/python3/files/python3-package-ncurses.mk2
-rw-r--r--lang/python/python3/files/python3-package-readline.mk16
3 files changed, 18 insertions, 3 deletions
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index ba1b6df5a..121a29054 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
include ../python3-version.mk
PKG_NAME:=python3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
@@ -270,7 +270,6 @@ define Py3Package/python3-light/filespec
-|/usr/lib/python$(PYTHON3_VERSION)/tkinter
-|/usr/lib/python$(PYTHON3_VERSION)/turtledemo
-|/usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_test*.so
--|/usr/lib/python$(PYTHON3_VERSION)/lib-dynload/readline*.so
-|/usr/lib/python$(PYTHON3_VERSION)/pdb.doc
-|/usr/lib/python$(PYTHON3_VERSION)/test
-|/usr/lib/python$(PYTHON3_VERSION)/webbrowser.py
diff --git a/lang/python/python3/files/python3-package-ncurses.mk b/lang/python/python3/files/python3-package-ncurses.mk
index 45649ac75..3ecdeb336 100644
--- a/lang/python/python3/files/python3-package-ncurses.mk
+++ b/lang/python/python3/files/python3-package-ncurses.mk
@@ -8,7 +8,7 @@
define Package/python3-ncurses
$(call Package/python3/Default)
TITLE:=Python $(PYTHON3_VERSION) ncurses module
- DEPENDS:=+python3-light +libncurses
+ DEPENDS:=+python3-light +libncursesw
endef
$(eval $(call Py3BasePackage,python3-ncurses, \
diff --git a/lang/python/python3/files/python3-package-readline.mk b/lang/python/python3/files/python3-package-readline.mk
new file mode 100644
index 000000000..4ce408db2
--- /dev/null
+++ b/lang/python/python3/files/python3-package-readline.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2021 Alexandru Ardelean <ardeleanalex@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Package/python3-readline
+$(call Package/python3/Default)
+ TITLE:=Python $(PYTHON3_VERSION) readline module
+ DEPENDS:=+python3-light +libreadline +libncursesw
+endef
+
+$(eval $(call Py3BasePackage,python3-readline, \
+ /usr/lib/python$(PYTHON3_VERSION)/lib-dynload/readline.$(PYTHON3_SO_SUFFIX) \
+))