aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python3
diff options
context:
space:
mode:
authorAlexandru Ardelean <alex@shruggie.ro>2023-01-25 14:03:29 +0200
committerAlexandru Ardelean <alex@shruggie.ro>2023-01-25 14:03:33 +0200
commit1f317dfb75216904c92c3c8a64e088fb6b4c551b (patch)
tree49d7b55af01020915e9cb7f56b165acbaf9091c0 /lang/python/python3
parentadce04d840ea0dee718455a51a576122c7a460a7 (diff)
python3: add 'ensurepip' to python3-pip sub-package
Fixes: https://github.com/openwrt/packages/issues/12707 Seems to work. Looking into the 'venv' lib, it seems it's installing pip & setuptools inside a virtual environment. `python3-pip` is already ~6 MB. This adds another ~3 MB. But, this gives users the ability to run Python virtual environments, which is a pretty common feature of Python in production cases (usually web stuff). Signed-off-by: Alexandru Ardelean <alex@shruggie.ro>
Diffstat (limited to 'lang/python/python3')
-rw-r--r--lang/python/python3/Makefile3
-rw-r--r--lang/python/python3/files/python3-package-pip.mk1
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 816b1f1da..aa2f2624f 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
include ../python3-version.mk
PKG_NAME:=python3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
@@ -272,7 +272,6 @@ define Py3Package/python3-light/filespec
+|/usr/lib/python$(PYTHON3_VERSION)
-|/usr/lib/python$(PYTHON3_VERSION)/distutils/cygwinccompiler.py
-|/usr/lib/python$(PYTHON3_VERSION)/distutils/command/wininst*
--|/usr/lib/python$(PYTHON3_VERSION)/ensurepip
-|/usr/lib/python$(PYTHON3_VERSION)/idlelib
-|/usr/lib/python$(PYTHON3_VERSION)/tkinter
-|/usr/lib/python$(PYTHON3_VERSION)/turtledemo
diff --git a/lang/python/python3/files/python3-package-pip.mk b/lang/python/python3/files/python3-package-pip.mk
index 8b547cee8..61ea48022 100644
--- a/lang/python/python3/files/python3-package-pip.mk
+++ b/lang/python/python3/files/python3-package-pip.mk
@@ -29,6 +29,7 @@ define Py3Package/python3-pip/install
endef
$(eval $(call Py3BasePackage,python3-pip, \
+ /usr/lib/python$(PYTHON3_VERSION)/ensurepip \
, \
DO_NOT_ADD_TO_PACKAGE_DEPENDS \
))