aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python3-pyroute2/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-21 03:03:12 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-30 23:16:18 +0800
commit635cb1309c4d52763c03bc00e7c367e06908b54f (patch)
treef4ab5d3c372741d39b2c0c9e9e34a0c007ca6d53 /lang/python/python3-pyroute2/Makefile
parent29ef2938d131ad862f28c2e6f09656351a4ca006 (diff)
treewide: Use pypi.mk for Python packages
This updates all Python packages that download their source from PyPi to use pypi.mk. This will allow future improvements/changes to pypi.mk to affect all relevant packages. This also makes it easier for future Python packages to start using pypi.mk, when it's clear how it is used in existing packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python3-pyroute2/Makefile')
-rw-r--r--lang/python/python3-pyroute2/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/python/python3-pyroute2/Makefile b/lang/python/python3-pyroute2/Makefile
index 1488e6dc2..875fe0d05 100644
--- a/lang/python/python3-pyroute2/Makefile
+++ b/lang/python/python3-pyroute2/Makefile
@@ -11,16 +11,14 @@ PKG_NAME:=python3-pyroute2
PKG_VERSION:=0.5.6
PKG_RELEASE:=1
-PKG_SOURCE:=pyroute2-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/p/pyroute2
+PYPI_NAME:=pyroute2
PKG_HASH:=deae0e6191a04c3ee213c6fae6ed779602ef5da5ca5e2fa533f27bc04326bfbe
-PKG_BUILD_DIR:=$(BUILD_DIR)/pyroute2-$(PKG_VERSION)
-
PKG_MAINTAINER:=Martin Matějek <martin.matejek@nic.cz>
PKG_LICENSE:=GPL-2.0-or-later Apache-2.0
PKG_LICENSE_FILES:=LICENSE.GPL.v2 LICENSE.Apache.v2
+include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk