aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-yarl
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-21 03:03:12 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-30 23:16:18 +0800
commit635cb1309c4d52763c03bc00e7c367e06908b54f (patch)
treef4ab5d3c372741d39b2c0c9e9e34a0c007ca6d53 /lang/python/python-yarl
parent29ef2938d131ad862f28c2e6f09656351a4ca006 (diff)
treewide: Use pypi.mk for Python packages
This updates all Python packages that download their source from PyPi to use pypi.mk. This will allow future improvements/changes to pypi.mk to affect all relevant packages. This also makes it easier for future Python packages to start using pypi.mk, when it's clear how it is used in existing packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-yarl')
-rw-r--r--lang/python/python-yarl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python/python-yarl/Makefile b/lang/python/python-yarl/Makefile
index d0aed33fa..08ac4382f 100644
--- a/lang/python/python-yarl/Makefile
+++ b/lang/python/python-yarl/Makefile
@@ -11,14 +11,14 @@ PKG_NAME:=yarl
PKG_VERSION:=1.3.0
PKG_RELEASE:=1
-PKG_SOURCE:=yarl-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/y/yarl/
+PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=024ecdc12bc02b321bc66b41327f930d1c2c543fa9a561b39861da9388ba7aa9
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
+include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk