aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-yaml
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-20 13:49:43 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-24 12:20:49 -0800
commitbd84d97be6a92eb0d9ea0b1f3b394f1499457a02 (patch)
tree57521e838ed0fe702da08c57f52754c22083f223 /lang/python/python-yaml
parenta7b5bfbfb75c07f05072e52224d3259648165916 (diff)
python-yaml: fix build with Cython 3
Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'lang/python/python-yaml')
-rw-r--r--lang/python/python-yaml/Makefile2
-rw-r--r--lang/python/python-yaml/patches/001-cython3.patch18
2 files changed, 19 insertions, 1 deletions
diff --git a/lang/python/python-yaml/Makefile b/lang/python/python-yaml/Makefile
index 837cc8d0d..92ac32841 100644
--- a/lang/python/python-yaml/Makefile
+++ b/lang/python/python-yaml/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-yaml
PKG_VERSION:=6.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=PyYAML
PKG_HASH:=bfdf460b1736c775f2ba9f6a92bca30bc2095067b8a9d77876d1fad6cc3b4a43
diff --git a/lang/python/python-yaml/patches/001-cython3.patch b/lang/python/python-yaml/patches/001-cython3.patch
new file mode 100644
index 000000000..fe3956c2c
--- /dev/null
+++ b/lang/python/python-yaml/patches/001-cython3.patch
@@ -0,0 +1,18 @@
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,3 +1,3 @@
+ [build-system]
+-requires = ["setuptools", "wheel", "Cython<3.0"]
++requires = ["setuptools", "wheel", "Cython"]
+ build-backend = "setuptools.build_meta"
+--- a/setup.py
++++ b/setup.py
+@@ -82,7 +82,7 @@ if 'sdist' in sys.argv or os.environ.get
+ with_cython = True
+ try:
+ from Cython.Distutils.extension import Extension as _Extension
+- from Cython.Distutils import build_ext as _build_ext
++ from Cython.Distutils.old_build_ext import old_build_ext as _build_ext
+ with_cython = True
+ except ImportError:
+ if with_cython: