aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-yaml
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-07-02 19:41:45 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-07-14 15:59:13 +0200
commit80cd2bb8b7a8a3f38ea819bcb8db8a803ab57f13 (patch)
tree438ccd1131617f1f90857bba903eb67ffa9c6d6e /lang/python/python-yaml
parent0cd608d26e8cbfb125651aa5b81e1065b09424d7 (diff)
python-yaml: update source and build for python3
Update source to version 3.12 and build for both, python and python3. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'lang/python/python-yaml')
-rw-r--r--lang/python/python-yaml/Makefile37
1 files changed, 30 insertions, 7 deletions
diff --git a/lang/python/python-yaml/Makefile b/lang/python/python-yaml/Makefile
index 3af2f0eeb..c6314c8b1 100644
--- a/lang/python/python-yaml/Makefile
+++ b/lang/python/python-yaml/Makefile
@@ -8,36 +8,59 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=PyYAML
-PKG_VERSION:=3.11
+PKG_VERSION:=3.12
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pyyaml.org/download/pyyaml/
-PKG_MD5SUM:=f50e08ef0fe55178479d3a618efe21db
+PKG_HASH:=592766c6303207a20efc445587778322d7f73b161bd994f227adaa341ba212ab
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
-PKG_BUILD_DEPENDS:=python
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-$(PKG_NAME)-$(PKG_VERSION)
+PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)
+$(call include_mk, python3-package.mk)
-define Package/python-yaml
+define Package/python-yaml/Default
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
- TITLE:=YAML parser and emitter for Python
URL:=http://pyyaml.org/wiki/PyYAML
- DEPENDS:=+python +libyaml
+ DEPENDS:=+libyaml
+endef
+
+define Package/python-yaml
+$(call Package/python-yaml/Default)
+ TITLE:=YAML parser and emitter for Python
+ DEPENDS+=+PACKAGE_python-yaml:python-light +PACKAGE_python-yaml:python-codecs
+ VARIANT:=python
endef
-define Build/Compile
+define Package/python3-yaml
+$(call Package/python-yaml/Default)
+ TITLE:=YAML parser and emitter for Python3
+ DEPENDS+=+PACKAGE_python3-yaml:python3-light
+ VARIANT:=python3
+endef
+
+define PyBuild/Compile
$(call Build/Compile/PyMod,,\
--with-libyaml install --prefix="$(PKG_INSTALL_DIR)/usr" \
)
endef
+define Py3Build/Compile
+ $(call Build/Compile/Py3Mod,,\
+ --with-libyaml install --prefix="$(PKG_INSTALL_DIR)/usr" \
+ )
+endef
+
$(eval $(call PyPackage,python-yaml))
$(eval $(call BuildPackage,python-yaml))
+$(eval $(call Py3Package,python3-yaml))
+$(eval $(call BuildPackage,python3-yaml))