aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-yaml
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-03-06 11:54:02 +0800
committerJeffery To <jeffery.to@gmail.com>2023-04-24 16:20:35 +0800
commit63d13aa15f847d35d7f7473e1595de6c9d53f655 (patch)
tree71a1de6365b5561ba0d0937336a8bffa1f2ebbd8 /lang/python/python-yaml
parent30bd279461faf52b153714eac28b613eef594b90 (diff)
python-libraries: Update build options
This updates the build options for these packages to work with the pyproject.toml-based build process, and removes PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-yaml')
-rw-r--r--lang/python/python-yaml/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/python/python-yaml/Makefile b/lang/python/python-yaml/Makefile
index 4e20fd209..7e02371e4 100644
--- a/lang/python/python-yaml/Makefile
+++ b/lang/python/python-yaml/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-yaml
PKG_VERSION:=6.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PYPI_NAME:=PyYAML
PKG_HASH:=68fb519c14306fec9720a2a5b45bc9f0c8d1b9c72adf45c37baedfcd949c35a2
@@ -21,8 +21,6 @@ PKG_CPE_ID:=cpe:/a:pyyaml_project:pyyaml
PKG_BUILD_DEPENDS:=python-cython/host
-PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1
-
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
@@ -40,7 +38,7 @@ define Package/python3-yaml/description
PyYAML is a YAML parser and emitter for the Python programming language.
endef
-PYTHON3_PKG_SETUP_GLOBAL_ARGS:=--with-libyaml
+PYTHON3_PKG_BUILD_VARS:=PYYAML_FORCE_LIBYAML=1
PYTHON3_PKG_SETUP_ARGS:=
$(eval $(call Py3Package,python3-yaml))