aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-yaml
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-21 03:03:12 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-30 23:16:18 +0800
commit635cb1309c4d52763c03bc00e7c367e06908b54f (patch)
treef4ab5d3c372741d39b2c0c9e9e34a0c007ca6d53 /lang/python/python-yaml
parent29ef2938d131ad862f28c2e6f09656351a4ca006 (diff)
treewide: Use pypi.mk for Python packages
This updates all Python packages that download their source from PyPi to use pypi.mk. This will allow future improvements/changes to pypi.mk to affect all relevant packages. This also makes it easier for future Python packages to start using pypi.mk, when it's clear how it is used in existing packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-yaml')
-rw-r--r--lang/python/python-yaml/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/lang/python/python-yaml/Makefile b/lang/python/python-yaml/Makefile
index 3a78d9558..73a9e4703 100644
--- a/lang/python/python-yaml/Makefile
+++ b/lang/python/python-yaml/Makefile
@@ -11,8 +11,7 @@ PKG_NAME:=python-yaml
PKG_VERSION:=5.1.2
PKG_RELEASE:=1
-PKG_SOURCE:=PyYAML-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/P/PyYAML
+PYPI_NAME:=PyYAML
PKG_HASH:=01adf0b6c6f61bd11af6e10ca52b7d4057dd0be0343eb9283c878cf3af56aee4
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
@@ -20,14 +19,11 @@ PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:pyyaml_project:pyyaml
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-PyYAML-$(PKG_VERSION)
-
+include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
include ../python3-package.mk
-PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
-
define Package/python-yaml/Default
SECTION:=lang
CATEGORY:=Languages