aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-yaml
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/python-yaml
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-yaml')
-rw-r--r--lang/python/python-yaml/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/lang/python/python-yaml/Makefile b/lang/python/python-yaml/Makefile
index cf0cb1225..a26b5724f 100644
--- a/lang/python/python-yaml/Makefile
+++ b/lang/python/python-yaml/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-yaml
PKG_VERSION:=5.3.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=PyYAML
PKG_HASH:=b8eac752c5e14d3eca0e6dd9199cd627518cb5ec06add0de9d32baeee6fe645d
@@ -23,25 +23,17 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python-yaml/Default
+define Package/python3-yaml
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=YAML parser and emitter for Python
URL:=https://github.com/yaml/pyyaml
- DEPENDS:=+libyaml
-endef
-
-define Package/python3-yaml
-$(call Package/python-yaml/Default)
- DEPENDS+=+PACKAGE_python3-yaml:python3-light
- VARIANT:=python3
+ DEPENDS:=+libyaml +python3-light
endef
define Package/python3-yaml/description
PyYAML is a YAML parser and emitter for the Python programming language.
-.
-(Variant for Python3)
endef
PYTHON3_PKG_SETUP_GLOBAL_ARGS:=--with-libyaml