aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-versioneer
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-10-31 11:42:05 +0800
committerTianling Shen <cnsztl@gmail.com>2023-11-02 00:27:11 +0800
commit8acd006b6e0d679fa60e5cdf263b90e940c6ccef (patch)
treea5daa99611b148a3d37649828d7d4aa21805b2fd /lang/python/python-versioneer
parent3e51eef14c3be57d1a5ac3c1ecd4150aa5d8e639 (diff)
python-versioneer: Add new host-only package
From the README: This is a tool for managing a recorded version number in setuptools-based python projects. The goal is to remove the tedious and error-prone "update the embedded version string" step from your release process. Making a new release should be as easy as recording a new tag in your version-control system, and maybe making new tarballs. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-versioneer')
-rw-r--r--lang/python/python-versioneer/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/lang/python/python-versioneer/Makefile b/lang/python/python-versioneer/Makefile
new file mode 100644
index 000000000..b21866a86
--- /dev/null
+++ b/lang/python/python-versioneer/Makefile
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-versioneer
+PKG_VERSION:=0.29
+PKG_RELEASE:=1
+
+PYPI_NAME:=versioneer
+PKG_HASH:=5ab283b9857211d61b53318b7c792cf68e798e765ee17c27ade9f6c924235731
+
+PKG_LICENSE:=Unlicense
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_HOST_ONLY:=1
+HOST_BUILD_DEPENDS:=python3/host python-build/host python-installer/host python-wheel/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-versioneer
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Easy VCS-based management of project version strings
+ URL:=https://github.com/python-versioneer/python-versioneer
+ DEPENDS:=+python3-light
+ BUILDONLY:=1
+endef
+
+define Package/python3-versioneer/description
+This is a tool for managing a recorded version number in
+setuptools-based python projects. The goal is to remove the tedious and
+error-prone "update the embedded version string" step from your release
+process. Making a new release should be as easy as recording a new tag
+in your version-control system, and maybe making new tarballs.
+endef
+
+$(eval $(call Py3Package,python3-versioneer))
+$(eval $(call BuildPackage,python3-versioneer))
+$(eval $(call BuildPackage,python3-versioneer-src))
+$(eval $(call HostBuild))