aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-unidecode
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-07-20 02:45:44 +0800
committerJeffery To <jeffery.to@gmail.com>2023-07-20 02:45:44 +0800
commit35d6cdf8bbbecb3795102dab5d2f22e86e43218f (patch)
tree1307c69c35784ab122a6613ba2b68f4188712196 /lang/python/python-unidecode
parentcaafb15e4bec8ff2fa9a62af19312fd2c438dbc8 (diff)
python3-unidecode: Update to 1.3.6, rename source package
This renames the source package to python-unidecode to match other Python packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-unidecode')
-rw-r--r--lang/python/python-unidecode/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/python/python-unidecode/Makefile b/lang/python/python-unidecode/Makefile
new file mode 100644
index 000000000..d8c150ac2
--- /dev/null
+++ b/lang/python/python-unidecode/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-unidecode
+PKG_VERSION:=1.3.6
+PKG_RELEASE:=1
+
+PYPI_NAME:=Unidecode
+PKG_HASH:=fed09cf0be8cf415b391642c2a5addfc72194407caee4f98719e40ec2a72b830
+
+PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-unidecode
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=ASCII transliterations of Unicode text
+ URL:=https://github.com/avian2/unidecode
+ DEPENDS:=+python3-light
+endef
+
+define Package/python-unidecode/description
+ Unidecode, lossy ASCII transliterations of Unicode text
+endef
+
+$(eval $(call Py3Package,python3-unidecode))
+$(eval $(call BuildPackage,python3-unidecode))
+$(eval $(call BuildPackage,python3-unidecode-src))