aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-twisted/patches
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-11-18 04:33:26 +0800
committerJeffery To <jeffery.to@gmail.com>2019-11-18 04:33:26 +0800
commitc56770a570d6e87b0bc06dba5c552f5f35253728 (patch)
tree7974a2d34baa09c17e051ced06e32ac4d33b6999 /lang/python/python-twisted/patches
parent5a334383a8ea21512cfbb2d3cc5c561d209eb5df (diff)
python-twisted: Update to 19.10.0, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-twisted/patches')
-rw-r--r--lang/python/python-twisted/patches/001-omit-tkconch.patch2
-rw-r--r--lang/python/python-twisted/patches/002-omit-tests.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/python/python-twisted/patches/001-omit-tkconch.patch b/lang/python/python-twisted/patches/001-omit-tkconch.patch
index 67a37bc1c..c975aa31a 100644
--- a/lang/python/python-twisted/patches/001-omit-tkconch.patch
+++ b/lang/python/python-twisted/patches/001-omit-tkconch.patch
@@ -1,6 +1,6 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -149,7 +149,6 @@ _CONSOLE_SCRIPTS = [
+@@ -150,7 +150,6 @@ _CONSOLE_SCRIPTS = [
"conch = twisted.conch.scripts.conch:run",
"mailmail = twisted.mail.scripts.mailmail:run",
"pyhtmlizer = twisted.scripts.htmlizer:run",
diff --git a/lang/python/python-twisted/patches/002-omit-tests.patch b/lang/python/python-twisted/patches/002-omit-tests.patch
index 51adbbdf8..2eb84d06a 100644
--- a/lang/python/python-twisted/patches/002-omit-tests.patch
+++ b/lang/python/python-twisted/patches/002-omit-tests.patch
@@ -1,6 +1,6 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -175,11 +175,6 @@ class ConditionalExtension(Extension, ob
+@@ -176,11 +176,6 @@ class ConditionalExtension(Extension, ob
# The C extensions used for Twisted.
_EXTENSIONS = [
ConditionalExtension(
@@ -12,7 +12,7 @@
"twisted.internet.iocpreactor.iocpsupport",
sources=[
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
-@@ -284,12 +279,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
+@@ -285,12 +280,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
"incremental >= 16.10.1",
"Automat >= 0.3.0",
"hyperlink >= 17.1.1",
@@ -26,7 +26,7 @@
use_incremental=True,
setup_requires=["incremental >= 16.10.1"],
install_requires=requirements,
-@@ -299,7 +293,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
+@@ -300,7 +294,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
cmdclass=command_classes,
include_package_data=True,
exclude_package_data={